Your comments

Okay, so I looked into the whole .dll thingy. I ended up getting sqlite3 from elsewhereand just replacing it annnd it works so far! 

Yeah, I'm starting to think it's an issue with my pc in particular. 
Yeah sqlite3.dll is there. I tried reimporting it and the error appears right after it adds the codebases. 
Also I'm using Windows 10.

Nah, I deleted Unity completely and made a new project once I installed 2017.1.  Should I install 2017.2?

So I tried running Bolt on my laptop with 2017.1.1f1, and I do not get these errors. I wonder what's wrong with my PC.