1. Project Setup

Let's start by getting our project ready.

1. Create a new 2D project

Create a new 2D project called BoltPlatformerTutorial.

2. Download and install Bolt

Open Window > Asset Store and search for Bolt. Once purchased and downloaded, click Import, then Import again in the new dialog:

After the import, the setup dialog will show. Follow the instructions on screen to install Bolt. For more information, see the manual:

Manual: Installation

For this tutorial, we will be using Human Naming. If you're an experienced programmer, you may choose Programmer Naming, but the names of the units in the fuzzy finders and in the graphs won't be the same as the ones shown in the screenshots along the tutorial.

3. Change the tags and layers settings

Open Edit > Project Settings > Tags & Layers and add new layers and tags so that your configuration is exactly like the following screenshot:

4. Change the collision matrix

Open Edit > Project Settings > Physics 2D and make your collision matrix match this one:

5. Download and import the tutorial assets

Click the link below to download the tutorial assets package, then import it in your project:


6. Add the tutorial scenes to the build settings

Open File > Build Settings... and drag & drop all the scenes inside the Scenes folder:

5. Open the first scene

Open the level 1 scene located at Scenes / Level1.

6. Setup your window layout

Finally, we'll open all the Bolt windows and setup a comfortable layout to work in. This part is personal, of course, but we have a few recommendations from our experience working with Bolt. 

Start by opening all the Graph, Graph Inspector and Variables windows from the Window menu:

If you have a single monitor, here is the layout we recommend. Note that on Windows, we moved our task bar to the side of the screen to get even more vertical space.

If you have dual monitors, we recommend using the second monitor entirely for Bolt graph editing, like so: 

Introduction Character Controller

This article was helpful for 39 people. Is this article helpful for you?


Would love to dedicate another display for Bolt graph editing, but all the popups, like fuzzy finder, appear on my primary display when I click on my second display. Things are also weird with animator window, so looks like it's Unity problem. Maybe there is a good solution for a nice multi-display editor workflow. Maybe I am doing something wrong. 


Hi, thanks for all the quick response,  here is my question, the character is not showing up in the scene view but it shows up in the game view, is there a reason?


Same happened to me about a month ago. I remeber playing with layers and got it okay.


I've downloaded and set up the scene, however the background is in front of everything else, even with all the layers added. How can I send the background to the back?

The layers sort themselves out when pressing play mode; it goes to the back but comes right to the front once you exit it.


In each asset, there is an option under Sprite Renderer. Most of the sorting layers are set to Default. This is causingf the background to be in front. If you play the game, to sorting order will be corrected. Change them to their appropriate tag. For instance, the platforms should be set to Platforms. You can select them all and make 1 change for all of them.

Oooh, I see now! Thank you so much Frank. :)

It appears the sorting layers had been corrupted by a previous export of the tutorial package. Reuploaded, hopefully they will be fixed now. Make sure to setup your layers & tags as indicated before importing the package though!

Still seem to be corrupt.