Aot List on Mobil not working

Elin 3 years ago updated by V M 2 years ago 15

After the Update to 1.2.2 and a Unit update Aot List and directory appear.

Thats my test Setup. In the Editor and in a Standalone build is everything working fine.
I run the AOT Prebuild without issues.
I can prefill Aot Lists or generate them on runtime.

But none of this is working on iOS or android.

Android Screenshot:

Unity 2017.2

BOlt 1.2.2

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Elin,

Sorry you're having this issue. Is there any warning or error in the console?

I don't have any mobil console tools 😕

On Pc no warning or error at all. 

Just in the mobil builds ( I tested local and cloud) the lists remain empty. 

I create a small debug consol with unity ui. But everything it says, is that the list is empty. 

I'm getting a little bit nervous, because i sat all on bolt for my current project and the client want in addition to the standalone mobile builds. 

Im struggling now, because everything falls with the lists. 

Can someone please tell me, if it is working on their side and it is just me or isn't it working at all?
I would love to find the bug but i have no Idea where to look without a console.

Got this out of the Android Monitor. Is this my Error?

I also got this error with a android debug asset. 

And this is the Error log from my currect project from the Android Monitor.


Oh wow

Somehow it works now.

After creating a 3rd test project. Switching to android before importing bolt.

Could it be, that unity had some old temp files and didn`t updated well?

Next Update
Android is now working fine.
But when building iOS with the cloud its still not working.
I bought now a mobil debug asset and got this error:

Hi Elin,

Sorry for the delay on this.

There seems to be 2 issues here:

1. The integer to string unit is bugged on AOT platforms. See this bug report:
Once you remove it, you shouldn't get the InvalidProgramException for invalid IL code.
It's a bit hacky, but using Format should be a workaround until I fix the ToString bug:

2. Using IList.Add is not compatible with AOT at the moment.
You should use Collections > Lists > Add List Item instead of List Interface > Add.

Can you tell me if you still get issues with these workarounds?

Hi Lazlo,

thanks for your support.

For the int to string problem i already found a work around, but with the add item to list note i got one wrong node inside of one of my macros.

Once you replace the node, does it work without issues?

Yes yes yes
Its works without any issues.
Puuu now i'm really relieved.

All this just because of one wrong node....

Now i feel stupid.

Thank you very much

Don't feel stupid! It's my job to make sure this is clear and error-proof. I'll try to remove interface methods from AOT Safe-Mode.

IList.Add still exists in Safe Mode. does this mean it works with AOT now?

It will be there unless you target an AOT platform in your build settings. If you target Standalone, it will show up even though it's not supported in AOT.

I set my build to WebGL.. not sure what you mean. I think that shouldn't matter anyway, if you have an AOT Safe Mode, that should be enough, and the only setting we need for Bolt to be working in AOT Safe Mode..