Cannot Reproduce

Assembly-CSharp.csproj error

ib1984 4 years ago updated by Ayrton Ribeiro 3 years ago 21


after updating Bolt to a Version 1.1.2 i'm getting error in Assembly-CSharp.csproj on lines below. Result is that you can't write any kind of script 'cause the code cannot compile nor you can use any of Unity's functions.

The problem exists both in a 2017.1 and 2017.2 versions of Unity3D.

I must say that i'm a bit angry because my own decision to migrate to visual scripting has only got me behind a project schedule and i actually have to deal with bugs in a release... sorry, but this just got me frustrated and i'm thinking right now to get back on track with plain scripting.

 <Reference Include="Antlr3.Runtime">
 <Reference Include="Bolt.Core.Editor">
 <Reference Include="Bolt.Core.Runtime">
 <Reference Include="Bolt.Flow.Editor">
 <Reference Include="Bolt.Flow.Runtime">
 <Reference Include="Bolt.State.Editor">
 <Reference Include="Bolt.State.Runtime">
 <Reference Include="Ionic.Zip">
 <Reference Include="Ludiq.Core.Editor">
 <Reference Include="Ludiq.Core.Runtime">
 <Reference Include="Ludiq.Graphs.Editor">
 <Reference Include="Ludiq.Graphs.Runtime">
 <Reference Include="Ludiq.Platforms">

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi ib! Welcome to the community!

I'm sorry you're getting errors that keep you from compiling. Thanks for providing the csproj file, but what is the error you are getting exactly?

Hi Lazio,

Thank you for your fast reply,

The error message below (inside the Monodevelop)

Error while trying to load the project 'L:\UnityProjects\2017.1\Project\Assembly-CSharp.csproj': An error occurred while parsing EntityName. Line 168, position 44.

Line 168 inside the file is


After i comment the line it shows another Line and then again after that shows another until i comment them all (like shown in a first post). It solves the error message, but then i'can use Unity's functions inside the code and it doesn't compile.

I've created a new Project just to test it out and the same problem stays. After that i've moved back to Unity's version 2017.1 and the same thing happens again after creating another empty project from scratch.

Maybe i'm doing something wrong, but i don't know what and i have a bunch of code to recreate in Bolt.

I just need to have ability to write my own custom code and use it in Bolt.

Please help,


Ivan Belačić

Ivan, what version of Mono are you using? Do you have the latest?

Hi William,

I am using Version 5.9.6 downloaded and installed with Unity version 2017.2

It seems the same version of Mono came with Unity version 2017.1 and also the same error happens.


Ivan Belačić

I figured you were. I asked because a few of us myself included ran in to issues related to not having it up to date, in my case also not having Visual studio up to date caused some issues. Worth a shot.

Ok, i will try to solve the issue by downloading & installing the newest version of Mono. It says that the latest stable release is 6.1 Service Release 1 (

I'll get back with a result after that.

Ivan Belačić

Can't hurt. If not, Lazlo has proven quite adept at figuring out issues related to Bolt and any supported/related systems.

I have reinstalled everything again (Unity3D and Mono) and i even tried to use Visual Studio and the same issue remains.

If this issue is not single system related then i believe that you are already working on a solution because this one is a major one.

Looking at the error, I don’t think it is related to Bolt. This is a file generated by Unity, it’s odd that it thinks there is an invalid symbol.  Are you using other plugins that might modify the project file? Because Bolt doesn’t change its contents.

Does this error happen in an empty pronect with just Bolt?

No, error manifests right after i install the Bolt plugin and after i remove the plugin issue is gone. I have created several new projects, clean and without any other plugin installed. I really don't know what to do.

Also, I am using the latest version of Bolt available to download on assetstore.

I have to mention that in previous version of Bolt this issue didn't exist.

I have uninstalled Unity app and erased installation folder then installed it again, started new empty Project, created a simple C# script, compiled without a problem.

After that i installed The Bolt plugin which works fine, no errors in editor, created a simple C# script and there goes the same error message again showing both in Mono and Visual Studio.

I hope there is a bypass of some kind or maybe i could downgrade to previous version of Bolt and downgrade Unity back to version 2017.1 and stick to the version lock system while on a project.

What hardware and OS are you using. I do not have this issue and have not heard anyone mention it until now?

Graphics: GTX 980

I could do the clean install of my computer, it is not a problem for me, but i didn't think that it could get to that.

As there is not much left to do to solve this issue I've decided to do the clean install of my computer.  

I will get back here with info afterwards.

I doubt it has to do with your OS installation, don’t go through that trouble just yet. It’s a weekend and I’m not at my work computer, but I could look into your project file later. Can you send the fiull .csproj file?

I did the clean install and everything works fine now.

I suppose it goes something like "no pain, no gain"... so tired right now, gonna have myself a beer.

Thank you very much on your support guys, especially because it is on weekend, i mean it.

Best Regards,

Ivan Belačić

Glad to hear it though Lazlo was probably correct and it was not your OS per say, you likely removed something else you had along with it that caused the issue though so I would take note of anything you change or add back that may cause that error again. 

I discovered

On the user see if there are any different characters. Mark & Mary Example

When I changed "&" to "" e "It worked.

I hope it will help you, even after a long time.