0
Need More Information

Bolt not working in Windows build

Balázs Sabransky 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 2

I have this issue where my flowcharts working fine in editor but in my windows build gives all sorts of errors in every scene that has any kind of flowcharts in it, right after the scene loads. I tried bolt in a new project, and it works fine. I copied my macros and some of my scenes in the new project. Works fine. But if i make a new scene in my old one and make a simple flowchart witch disables the sprite renderer on start (so i can see that uts working) i gat these erros when the scene loads in the build:

Failed to deserialize scriptable object.

System.Runtime.Serialization.SerializationException: Deserialization into 'Bolt.FlowMacro' failed. ---> System.InvalidOperationException: Internal Deserialization Error - Object definition has not been encountered for object with id=11; have you reordered or modified the serialized data? If this is an issue with an unmodified Full Serializer implementation and unmodified serialization data, please report an issue with an included test case.

I tried reimporting bolt but its not working.

Bolt Version:
1.4.11
Unity Version:
2019.3.1f1
Platform(s):
Windows
Scripting Backend:
Mono
.NET Version (API Compatibility Level):
.NET 4.x

i dont have any bolt addons. i get no errors or warnings in the editor while palying. i only get them in the build.

Need More Information

Hi Balazs,

Sorry you're experiencing this issue.

First check, are you building for IL2CPP / AOT? If so, did you run Tools > Ludiq > AOT Pre-Build before building?

If that doesn't apply, I will need:

  • Screenshots of the graph that fails
  • Full stack trace of the error

Thanks!