0
Need More Information

a9 : More than one singleton error

CSmith 2 years ago updated 2 years ago 3

a9 complaining of more than 1 singleton upon going into play mode.  But there is still only one container I can see.  See image.



Bolt Version:
2.0.0.09
Unity Version:
2019.3
Platform(s):
OSX
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
Need More Information

Hi CSmith,

Are you using the domain or scene reload skipping option by any chance?

If you are, does the error go away when you disable it?

Otherwise I would need reproduction steps for the error.

UPDATE:

Enable and disabled the Domain Reload and it made no difference.  Same error either way.

Attempt to reproduce from scratch:

Deleted all objects and started over.  Cannot reproduce either with without the Domain Reload check box being enabled.

Possible clues as to the problem:

When it was failing, there was weird behavior after adding a Tween at one point.  To where the Tween would be wrapped in DontDestroyOnLoad but the Bolt Singleton Container would not.  Like the Tween interfered with the process.  From that point on, the Container would never be wrapped in the DDonLoad.  

I tried reproducing by adding in Tweens but it all worked together nicely with no error, so not sure how to reproduce as of yet.

CLUE #2:

Just happened again on a new scene from scratch.

I have a singleton that works perfectly fine on play.  It gets wrapped in a DDonLoad.

When I drag in an event to listen to from another class (happens to be component) two things happen.

When I don't pipe in a class ref to the input of the event, I get a no sub-type error.

When I do pipe in a valid class that it's from, The singleton stops being wrapped in DDonLoad and I get the error about having duplicate singletons in the scene.