Cannot Reproduce

Custom event will not pass arguments if the first argument stays the same

HeathClose 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 5

here you can see I have tried to send 2 arguments, increasing the number of the second by one each time... here it shows 6 attempts...

here is a gif of the goals manager receiving the event

If I concat the first argument with the second, changing the name passes the arguments...

UPDATE - apparently even the workaround doesn't solve the issue 100% of the time....

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
.NET 4.x

Hello HeathClose,

Sorry you're experiencing this issue and thanks for submitting a bug report. You should hear back from the developer soon!

Kind regards,

Hasan from Ludiq


Hi HeathClose, thanks for your patience on this.

I'll try reproducing the issue on my end, this is odd, it's the first I hear of this. Is there anything very specific on your setup or does it always happen even on simple Custom Events (w/o variables or other objects involved)?

I haven’t tried with literals but I’ve seen this before actually, I just wasn’t able to report it at the time so I knew about this but forgot this could happen until I used it again (passing arguments) in this project.

Need More Information

Hi HeathClose,

I'll need either scene/macro files or clearer step-by-step instructions to reproduce, as a simpler test case here does who the event being fired multiple times despite the arguments staying identical:


Cannot Reproduce

Hi HeathClose,

I'm closing this as Cannot Reproduce as there has been no activity or reliable repro steps in the last two months.

Feel free to comment again if you have more information!