Need More Information

Potential deadlock when loading unit options in specific project

Dimaz 2 years ago updated 2 years ago 14 1 duplicate

i got this error every time i open my project, im not sure what's wrong

i tried to rebuild the unit options as suggested, but it keeps coming back

Failed to fetch unit options for fuzzy finder (error log below).

Try rebuilding the unit options from 'Tools > Bolt > Build Unit Options'.

System.TimeoutException: Time-out exceeded on Unity API thread function delegate. Potential deadlock.

at Ludiq.UnityAPI.Await[T] (System.Func`1[TResult] func, System.Nullable`1[T] timeout) [0x0007a] in C:\Users\lazlo\Projects\Bolt1\Package\Ludiq.Core\Editor\Utilities\UnityAPI.cs:149

at Ludiq.UnityAPI.Await[T] (System.Func`1[TResult] func) [0x00000] in C:\Users\lazlo\Projects\Bolt1\Package\Ludiq.Core\Editor\Utilities\UnityAPI.cs:108

at Bolt.UnitBase.Subset (Bolt.UnitOptionFilter filter, Ludiq.GraphReference reference) [0x00029] in C:\Users\lazlo\Projects\Bolt1\Package\Bolt.Flow\Editor\Options\UnitBase.cs:377

at Bolt.UnitOptionTree.Prewarm () [0x00015] in C:\Users\lazlo\Projects\Bolt1\Package\Bolt.Flow\Editor\Options\UnitOptionTree.cs:44


Bolt.UnitOptionTree:Prewarm() (at C:/Users/lazlo/Projects/Bolt1/Package/Bolt.Flow/Editor/Options/UnitOptionTree.cs:48)

Ludiq.<>c__DisplayClass21_0:b__0() (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:278)

Ludiq.FuzzyWindow:Work() (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:1064)


Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
.NET Standard 2.0

Duplicates 1

Need More Information

Hi TowerCrow,

Thanks for the report.

Can you send the ScritableObject script that causes the issue to start happening?

this problem occurs everytime i open my project,

and i got this error alongside it:

TimeoutException: Time-out exceeded on Unity API thread action delegate. Potential deadlock.
Ludiq.UnityAPI.Await (System.Action action, System.Nullable`1[T] timeout) (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Utilities/UnityAPI.cs:92)
Ludiq.UnityAPI.Await (System.Action action) (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Utilities/UnityAPI.cs:53)
Bolt.UnitOptionTree+d__37.MoveNext () (at C:/Users/lazlo/Projects/Bolt1/Package/Bolt.Flow/Editor/Options/UnitOptionTree.cs:285)
System.Collections.Generic.LargeArrayBuilder`1[T].AddRange (System.Collections.Generic.IEnumerable`1[T] items) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
System.Collections.Generic.EnumerableHelpers.ToArray[T] (System.Collections.Generic.IEnumerable`1[T] source) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
System.Linq.Enumerable.ToArray[TSource] (System.Collections.Generic.IEnumerable`1[T] source) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
Ludiq.FuzzyWindow.Populate (Ludiq.FuzzyOptionNode node, System.Collections.Generic.IEnumerable`1[T] childrenValues, System.Nullable`1[T] cancellation) (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:23)
Ludiq.FuzzyWindow+<>c__DisplayClass21_0.b__0 () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:280)
Ludiq.FuzzyWindow.Work () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:1064)
Ludiq.FuzzyWindow:Work() (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:1069)

it happens when i right clicked on the graph to add new unit, for the first time after i open the project

there will only be few units displayed at first, but after i left click to close the add unit window and right click again, it shows all the units.

I have the same issue. Did you perhaps add any new types recently? This started to appear once I added my scriptable objects and regenerated units. Then every time at startup it'll behave exactly as you described. After the initial hangup it seems to work fine though. 

Need More Information

Hi Dimaz & TowerCrow,

Sorry about the issue. As I said in the other related thread, I'd need to know when that issue started happening exactly in order to be able to debug it. If you have any relevant project files that cause it, please upload them or send them to support@ludiq.io.

@TowerCrow here's what i added:

Assemblies: unity.TextMeshPro

Units: String Builder, Async Operation

@Lazlo im not sure exactly when it all started...

here's what happens every time when i load the project and tried to right click

I tried to reproduce the issue on a fresh project with the same exact Store assets and Unit Options setup. I was not successful, it works fine in the fresh project which would indicate some kind of corruption in the main project. 

EDIT: I wiped Bolt from the main project and reinstalled clean, I don't get this issue anymore after reinstall. However, I now get this error: [REDACTED]

EDIT2: Nevermind, the Setup Wizard didn't accept my manually added assemblies and types, didn't actually generate them. My macros are all destroyed though. Gonna discard the changes and roll back to the corrupted Bolt installation, at least I can work with that.

EDIT3: Saved my macros by reimporting the project!

EDIT4: Meh, didn't save all of them. 

So in conclusion, a clean install is a solution, except it wrecks the project up. 

Hi TowerCrow,

Any update on this?

@Lazlo, i sent an email just now with a stripped project attached, and how it keeps reappearing on my project and how to recreate the problem.

Hi Dimaz,

Sorry for the delay. I can't seem to find your email in our private tickets. Do you remember the title or any content to help me filter?

it's fuzzy finder error, my email is dimaz.a.zaki@gmail.com

Also, I notice you're using Bolt 1.4.9. Could you please update to the latest version (1.4.11) and confirm that the issue is still ocurring?

so yeah, i update it to 1.4.11 but the bug is still there

tried a clean install the bug is not there

but the moment i import my assets, it's back again

i think the only solution just like TowerCrow said is to clean install and not importing any macros ?