Cannot Reproduce

Bolt just stopt recognizing custom code/script (scriptable object code)

Mennovandijk 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 2

I have set a scriptable object in the object variables.
Getting variables has been setup in another part of the flow yesterday.
Today it seems that I cannot find the scriptable object units anymore. 
So first I rebuilt the bolt units but that didn't work. I notice in the 'type options' windows at the time when I added the sciptable object, bolt could find it. Now Bolt doesn't
I also tried deleting the unitoptions.db and rebuild the units but still no custom scrips in the fuzzy finder :-(

As you can see, today the "LevelStats" code is not recognized anymore, while I added it yesterday as seen in the dropdown above.

Bolt Version:
Unity Version:
windows 10
Scripting Backend:
.NET Version (API Compatibility Level):
.NET Standard 2.0

I managed to get things working again by doing the following:
- Close Unity
- Delet the "ArtifactDB" file in the Library folder in the root of the project.
- Restart Unity

Then Unity itself will rebuild this file and it is working again.

Cannot Reproduce

Hi Mennovandijk,

Sorry for the late reply. I'm not sure how I could reproduce this issue on my end, so I'll close this ticket. If ever you can consistently reproduce it in the future, please let me know the steps and I'll have a look.