Unity Bug

FileNotFoundException on UnityEngine.UI Assembly

Mennovandijk 2 years ago updated 2 years ago 3

I recently got 2 errors when opening my project and I can't figure out what they mean.

Anyone has an idea how I can solve these?


Bolt Version:
Unity Version:
windows 10
Scripting Backend:
.NET Version (API Compatibility Level):
.NET Standard 2.0
Satisfaction mark by Mennovandijk 2 years ago
Need More Information

Hi Mennovandijk,

The first error seems related to this Unity bug report: https://issuetracker.unity3d.com/issues/unityengine-dot-ui-reference-is-missing-in-assembly-definition-assemblies-and-plugins

Could you try updating to a later 2019.2 or 2019.3 version and see if it fixes it?

The second error might go away once the first is fixed.

Unity Bug

Hi Mennovandijk,

While investigating another issue, I noticed this was a problem when first-importing or re-importing a Bolt project on Unity 2019.2. Restarting Unity or entering/exiting play mode seems to fix it, and it doesn't seem to happen on Unity 2019.3+.

I'll close this as Unity Bug for now. Let me know if you have a persistent issue that stems from this after restarting Unity.

Hi Lazlo, thanks for letting me know. 
At the moment these error are solved since I move to 2019.3 (beta). I do encounter some other problem on ios and textmesh pro ant I am checking out if bolt is also part of this. (probably something to do with aot lists not working) but for now this original issue has been solved :-)