0
Not a Bug

[Beginner] instantiated game object doesn't run scripts

briers.matisse 1 year ago updated by Lazlo Bonin (Lead Developer) 1 year ago 4

Hi all, I recently started using bolt and as a beginners project I tried to make a flappy bird-like game


the player would be represented by a cube and the pipes by a simple sphere that would keep on respawning in a fixed x and z coordinate and a random y coord (ranging from 0.5 to 6) however when I tried to instantiate the sphere, the clone would simply not do anything. normally you'd see some circles floating through your graph wich I guess would indicate the script being run but now it didn't.

If there is more info i should provide you with, please let me know and i'll try to respond as fast as possible 

Thanks :D

Bolt Version:
1.4.5
Unity Version:
2018.2.1f1
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Need More Information

Hi Briers,

I would indeed need some more information.

Is it a Bolt machine that's not running, or a C# script?

How do you instantiate the object?

Does it show as active and enabled (checkboxes checked) in the inspector?

Hi Lazlo,

After some playtesting if found out that the clone did not have the checkbox next to the flow machine component checked.

I instantiated the object by using the "Game Object : instantiate (original, position, rotation)" option.

I hope this answered your questions and feel free to ask for more information if not :D

Not a Bug

Hi Briers,

Make sure the prefab you're instantiating from has the flow machine component enabled and it should be fine then! :) Closing this, let me know if you have any further issue.