Cannot Reproduce

Bolt Editor not working when adding audio mixer...

tasos bakas 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 3

A bit of a strange one..

I have a Unity project where I use BOLT and it all works fine, until I import some audio files and create an audio mixer.

From that point on, the existing macros still work and I can create new ones, but I cannot edit anything. If I right click or pull the arrow, there's no dropdown to choose from etc.. 

Even if I now delete the mixer asset and the audio files, it still doesn't work.

I get this error:

Any ideas??
Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Tasos,

Sorry you're experiencing this issue.

Can you run me through the exact steps to trigger the error in a minimal Unity project?



Sorry for slow response; I tried to replicate the issue and, actually, it looks like it's not about audio mixer at all. It's even stranger!

If I have a second screen connected to my mac and the flow editor is on a different screen to the main Unity editor, that's when it doesn't work! If I drag the editor to the same screen, then it does..

So, I can do my job fine, but it's still a strange bug!

Many thanks,


Cannot Reproduce

Hi Tasos,

I will close this as Cannot Reproduce for now, let me know if you ever find consistent reproduction steps I could recreate to fix the issue.