Cannot Reproduce

In IL2CPP build no code works

Crystalius 2 years ago updated 2 years ago 14


Just want my game to run faster and tried building with IL2CPP and no code works while in mono's build everything's fine.

Seems like a hidden problem with an endless chain reaction of errors.


Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Did you run AOT Pre-Build? IL2CPP is an AOT platform.

Didn't know that. Same with AOT Pre-build

Similar problem here.

Bolt Version:1.4.4, (.NET 4.x)

Unity Version:2019.1.6f1,

Build a windows standalone with IL2CPP, but everything stopped working in standalone build.

However, It looks worked after build AOT Pre-Build.

But the Untiy editor always crash after the AOT Pre-Build completed.

I don't get editor crashes but build crashes after some time. Tried Pre-Build again and then build the game and same thing happens, no code works. 

Is it the same log/error or is it different now that you ran AOT Pre-Build?

here's log after AOT Pre-Build output_log.txt


Is IL2CPP going to work soon? I would like to ship my game having better performance than Mono in a couple of months :) 

Well if it's only a few fps it's not very important. But if it would stop me publishing to other platforms it would be bad.

Best wishes 😊

Hi Crystallius,

Sorry about the late reply, I was on vacation the past two weeks.

From the output log you provided, it looks like the issue is that UnityEngine.SkinnedMeshRenderer is excluded from your build when using IL2CPP. Can you confirm that there are AOT stubs for SkinnedMeshRenderer, specically the Enabled property, in the generated AotStubs.cs file in your project? If not, there's a problem because you're using it in your graphs, but it's not being stubbed.


Yep, got them: 
// UnityEngine.SkinnedMeshRenderer.enabled
// UnityEngine.SkinnedMeshRenderer.op_Equality
// UnityEngine.SkinnedMeshRenderer.op_Implicit
// UnityEngine.SkinnedMeshRenderer.op_Inequality

Tried again, got new log if you like Output_log.txt


Alright, thanks for confirming, I'll do some reproduction tests on my end.

Cannot Reproduce

Ok, so unfortunately I cannot get this to reproduce in a minimal scene.

I have a simple flow graph like so:

(I also have a SMR component on the GO, of course).

In builds (I set my Standalone backend to IL2CPP to force AOT) and in the editor, I can successfully log the message after disabling the SMR.

Please provide reproduction steps or a minimal example project in which the issue happens!

It would take too much time to find out the cause. Only if building for another platform I want will fail I would try to find the cause. If there will be no such problems I will just wait for Bolt2 for IL2CPP, I guess that kind of problems won't happen there 😌. Maybe some assets I use interferes secretly or something. I use MeshAnimator for better performance animations. 

Updated to 2018.4.5 LTS, updated many assets and the problem is gone, but performance is slightly better with mono and IL2CPP game always crashes after quitting