Cannot Reproduce

Odin doesn't generate AOT bindings

Yuyu 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 7

Hi Bolt Team,

Not sure if it's a known bug, when I run my scene with a simple Flow Macro, my PS4 application stuck at the Unity logo screen.

Repro steps are:

1. Make a simple scene with a few basic 3D objects.

2. Add a Flow Macro to one of the object.

3. Add a new float Graph Variable named "MyFloat".

3. Add a "Set Variable" unit and set the "MyFloat" to any literal number.

4. Connect the "Set Variable" with "Start" event.

5. Generate the C# script.

6. Build the scene with PS4 settings.

7. Launch the application on PS4, notice it stuck at the "Unity" screen.

The unity version we use for now is "2018.3.10f1".

Thanks for the help.

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
Pending Review

Hi Yuyu,

Can you enable debugging on your PS4 build and show us the log or stack trace? Hard to guess what might be happening without more information. Thanks!



Hi Lazlo,

Thank you so much for your support, the log files are attached, some of them seem to be related to AOT, does bolt2 come with the option "AOT Pre-Build" as bolt1 ?


Hi Yuyu,

Interesting, yes it seems to be related to AOT, but basically it's the Odin AOT bindings that are missing. I have yet to integrate their build process step in ours, I'll see about that for the next alpha. I didn't think people would be testing the Alpha on AOT platforms so early! ;)

Hi Lazlo

I saw the line in the changlog of the latest version:

Legacy AOT collections failing to deserialize with Odin

Not sure if it would address the issue or not, however after I upgraded to the latest version, the PS4 crashed during preloading, the callstack seems close to what's described in THIS post.

Any ideas ?


Working on Fix

Hi Yuyu,

Unfortunately, that fix was related to another issue and did not address this one.

It is also a different issue from the post that you linked, because your issue is related to Odin Serializer in Bolt 2, whereas the other is linked to Full Serializer in Bolt 1.

I have a good idea on how to fix it, but it might not land soon because we don't prioritize bugfixes in alpha versions, sorry.

Need More Information

Hi Yuyu,

Sorry for the very late reply on this.

Looking at our Odin integration with the build pipeline, the AOT support scan and DLL should be properly executed upon build.

I'd be curious to know if you still get the same issue with the latest alpha, now that we have introduced classes and got rid of the old AOT Pre-Build system. 

Cannot Reproduce

This issue should be moot now with the new class variable system and Odin fixes. Let me know if ever you experience it in newer alphas.