Bolt 2.0.0a5 Compatiablity Errors With Unity 2019.1.1f1

abrownbag 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 9

Basically I create a new project (unity 2019 version 1.1 or 1.0) and add bolt two.
Run through bolts setup and do a full or fast extract.
Press play and everything fine.
Click an object and add component flow graph and I get this:

Upon following the error I'm brought to:

Specifically the error is on the the last line (isDirty)
After checking it in unity's docs I guess it has something to do with prefabs?
Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2

Same error:

AmbiguousMatchException: Ambiguous match found.
System.RuntimeType.GetMethodImpl (System.String name, System.Reflection.BindingFlags bindingAttr, System.Reflection.Binder binder, System.Reflection.CallingConventions callConv, System.Type[] types, System.Reflection.ParameterModifier[] modifiers) (at <1f0c1ef1ad524c38bbc5536809c46b48>:0)
System.Type.GetMethod (System.String name, System.Reflection.BindingFlags bindingAttr) (at <1f0c1ef1ad524c38bbc5536809c46b48>:0)
Ludiq.EditorUnityObjectUtility..cctor () (at Assets/Ludiq/Ludiq.Core/Editor/Utilities/EditorUnityObjectUtility.cs:25)
Rethrow as UnityEditorInternalException: An error occured while accessing internal Unity Editor functions. This might happen if Unity makes backward-incompatible changes in their newer versions of the editor.
Ludiq.EditorUnityObjectUtility..cctor () (at Assets/Ludiq/Ludiq.Core/Editor/Utilities/EditorUnityObjectUtility.cs:44)
Rethrow as TypeInitializationException: The type initializer for 'Ludiq.EditorUnityObjectUtility' threw an exception.
Ludiq.AnnotationUtility.GetAnnotation (System.Type type) (at Assets/Ludiq/Ludiq.Core/Editor/Utilities/AnnotationUtility.cs:117)
Ludiq.AnnotationDisabler.DisableGizmos () (at Assets/Ludiq/Ludiq.Core/Editor/Interface/Annotations/AnnotationDisabler.cs:15)
Ludiq.SetupCompletePage.OnShow () (at Assets/Ludiq/Ludiq.Core/Editor/Windows/SetupWizard/SetupCompletePage.cs:43)
Ludiq.Page.Show () (at Assets/Ludiq/Ludiq.Core/Editor/Windows/Page.cs:64)
Ludiq.Wizard.set_currentPage (Ludiq.Page value) (at Assets/Ludiq/Ludiq.Core/Editor/Windows/Wizard.cs:33)
Ludiq.Wizard+<>c__DisplayClass20_0.b__0 () (at Assets/Ludiq/Ludiq.Core/Editor/Windows/Wizard.cs:55)
Ludiq.Page.CompleteSwitch () (at Assets/Ludiq/Ludiq.Core/Editor/Windows/Page.cs:38)
Ludiq.Wizard.Update () (at Assets/Ludiq/Ludiq.Core/Editor/Windows/Wizard.cs:91)
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <1f0c1ef1ad524c38bbc5536809c46b48>:0)
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <1f0c1ef1ad524c38bbc5536809c46b48>:0)
System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at <1f0c1ef1ad524c38bbc5536809c46b48>:0)
UnityEditor.HostView.Invoke (System.String methodName, System.Object obj) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:345)
UnityEditor.HostView.Invoke (System.String methodName) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:339)
UnityEditor.HostView.SendUpdate () (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:463)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:200)

Temp fix (Thanks to Elringus on Discord!): Replace line 25 of Ludiq\Ludiq.Core\Editor\Utilities\EditorUnityObjectUtility.cs with:

EditorUtility_IsDirty = typeof(EditorUtility).GetMethods(BindingFlags.Static | BindingFlags.NonPublic | BindingFlags.Public).Where(m => m.Name == "IsDirty").First();

i get the same error, please fix!

Working on Fix

Hi everyone, thanks for the report.

Sorry, it seems like I missed that one while testing, seems fairly easy to fix. Will try to fix ASAP, maybe just post a hotfix to Alpha 5.


That would be awesome <3
(Trying to mess around with 2019 and bolt 2 right away)

Hey Lazlo, appreciate your quick response!

Any ETA yet?

Following errors accured when installing 2.0.0a5 today (2019-05-09). Unity 2019.1.1f1.

Fixed in Alpha

Thanks for the report everyone, I fixed it and I'll be uploading a version of the Alpha 5 with the fix later today.