Cannot Reproduce

Clicking Graph Inspector bounces selection to Flow State for the Graph Inspector and Variables tab

Vong 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 4

 Anecdotally I think I've been experiencing this throughout the 1.4.1 betas but hadn't been able to pinpoint what triggers it or what triggers it going back to normal..

Sometimes, the Graph Inspector will behave weirdly for an extended period of time. When you click inside the Graph Inspector anywhere (blank space or text field etc [edit: as well as the variable tab apparently]) it will seemingly bounce the selection as if you were selecting either 

  • the flow state as if selected in the state graph 
  • the state graph itself

The Variable tab also bounces likewise (so the graph vars tab may become grayed out when it gets bounced to the State graph level) but the Flow Graph tab stays the same.

Used to restart Unity to fix, but sometimes going to Play Mode fixes it. Sadly, most of the time I do a bunch of things and can't figure out what fixed it though.

Seems to only affect Flow graphs and super units that exist within a State graph. Seems to be no difference whether embeded or maco. When the bug is active, opening the flow graph independently from the Hierarchy tab has it acting normally there though.

A bit rambly.. hope that's enough to go on to find the bug..

[Edit: clicking any other window apparently bounces it. So more likely linked to the Flow Graph tab losing focus?]

[Edit: Doesn't need to be nested in a State Graph. Things nested in a Flow Graph also exhibits the same behaviour]

    Bolt Version:
    Unity Version:
    Scripting Backend:
    .NET Version (API Compatibility Level):
    Pending Review

    Hi AiSard,

    Thanks for reporting the issue. Your report reminds me of another bug related to the active hot control that Unity uses to determine which widget (button, tab, etc.) has focus in the editor.

    Unfortunately I don't have enough information to reproduce it. But can you try:

    • Changing the order / layout of your editor tabs
    • Editing in full screen mode (maximized graph) vs. docked tab mode

    And see if you can figure out some kind of logic to the issue?

    While moving around Editor tabs... I realized I had another Flow Graph tab open behind my normal Flow Graph tab etc. (floating, might have been docked with a Game tab, I closed it too fast) which I'm guessing was opened when I hit Edit Graph (as sometimes that opens in a new tab rather than the existing tab for some reason, haven't figured out what situations trigger that either though) Closing the second Flow Graph fixed it.

    But I'm thinking that a second Flow Graph probably shouldn't be causing that reaction?..
    Reopening a second Flow Graph now doesn't reintroduce the bug either...(docked/undocked/nested with a Game tab etc.)

    Edit: I think the second flow graph was empty before I closed it... which shouldn't be the case as my main one was showing stuff due to selecting a gameobject with attached graph at the beginning of the session.. weird detail..

    Some additional info (not sure if helpful): I've since upgraded the project to 2018.3.3f1 (not enough space to have that many concurrent Unity versions sadly) which initially added to the issue by having the focus of the Graph Inspector seemingly stuck on "the flow state as if selected in the state graph". But having the Graph Inspector tab not nested with any other tabs returned it to the initially reported behaviour. Didn't get around to trying full-screen before the second flow graph was discovered and whatever was going wrong behind the scenes undid itself though sorry

    Update: Have started using a second Flow Graph tab recently and bug has returned. Seems to be as you said and has something to do with widget focus. Still no idea of what triggers it specifically, just that it happens when I've two Flow Graphs open.

    Have figured out that, to get it out of its confused state just requires selecting the other Flow Graph tab though.

    Not sure if at all related, but been getting this message lately (not during the bug) only mentioning because it mentions hotcontrol:

    Should not be capturing when there is a hotcontrol
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
    Cannot Reproduce

    Hi AiSard,

    Sorry for the late reply on this.

    I'll mark this as CR for now; please do let me know if you ever find a consistent way of reproducing the bug.