+1
Cannot Reproduce

ArgumentNullException: Value cannot be null.

Skypatcher 2 years ago updated by Antonio Rojas 3 months ago 10

I was programming using Bolt without problem for a few hours. When I click the small circle next to the GameObject field (which was pre-filled in with Self). The dialog is empty (very strange). The scene was already added in the Build window. I decided to restart Unity, the Startup wizard pop up automatically, But it won't pass the naming convention step. I can't reinstall Bolt.  Attached below is the error message in the console.

I am not sure if it is Bolt's bug, may be Bolt was corrupted? Any one had similar problem before?

When I try to re-import Bolt from the Asset store, it said: Nothing to import, all assets from this package are already in the project.

ArgumentNullException: Value cannot be null.
Parameter name: target
Ludiq.PluginConfiguration.SaveProjectSettingsAsset () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Plugins/PluginConfiguration.cs:128)
Ludiq.ProjectSettingMetadata.Save () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Meta/ProjectSettingMetadata.cs:38)
Ludiq.PluginConfiguration.Save () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Plugins/PluginConfiguration.cs:51)
Ludiq.NamingSchemePage.OnContentGUI () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Plugin/NamingSchemePage.cs:54)
Ludiq.Page.DrawContent () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Windows/Page.cs:70)
Ludiq.Wizard.OnGUI () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Windows/Wizard.cs:106)
Ludiq.WrappedEditorWindow.OnGUI () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Windows/WrappedEditorWindow.cs:51)
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at :0)
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at :0)
System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at :0)
UnityEditor.HostView.Invoke (System.String methodName, System.Object obj) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:342)
UnityEditor.HostView.Invoke (System.String methodName) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:336)
UnityEditor.HostView.OldOnGUI () (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:129)
UnityEngine.Experimental.UIElements.IMGUIContainer.DoOnGUI (UnityEngine.Event evt, UnityEngine.Matrix4x4 worldTransform, UnityEngine.Rect clippingRect, System.Boolean isComputingLayout) (at C:/buildslave/unity/build/Modules/UIElements/IMGUIContainer.cs:266)
UnityEngine.Experimental.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, UnityEngine.Matrix4x4 worldTransform, UnityEngine.Rect clippingRect) (at C:/buildslave/unity/build/Modules/UIElements/IMGUIContainer.cs:438)
UnityEngine.Experimental.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e) (at C:/buildslave/unity/build/Modules/UIElements/IMGUIContainer.cs:421)
UnityEngine.Experimental.UIElements.IMGUIContainer.HandleEvent (UnityEngine.Experimental.UIElements.EventBase evt) (at C:/buildslave/unity/build/Modules/UIElements/IMGUIContainer.cs:401)
UnityEngine.Experimental.UIElements.EventDispatcher.ProcessEvent (UnityEngine.Experimental.UIElements.EventBase evt, UnityEngine.Experimental.UIElements.IPanel panel) (at C:/buildslave/unity/build/Modules/UIElements/EventDispatcher.cs:511)
UnityEngine.Experimental.UIElements.EventDispatcher.Dispatch (UnityEngine.Experimental.UIElements.EventBase evt, UnityEngine.Experimental.UIElements.IPanel panel, UnityEngine.Experimental.UIElements.DispatchMode dispatchMode) (at C:/buildslave/unity/build/Modules/UIElements/EventDispatcher.cs:307)
UnityEngine.Experimental.UIElements.BaseVisualElementPanel.SendEvent (UnityEngine.Experimental.UIElements.EventBase e, UnityEngine.Experimental.UIElements.DispatchMode dispatchMode) (at C:/buildslave/unity/build/Modules/UIElements/Panel.cs:176)
UnityEngine.Experimental.UIElements.UIElementsUtility.DoDispatch (UnityEngine.Experimental.UIElements.BaseVisualElementPanel panel) (at C:/buildslave/unity/build/Modules/UIElements/UIElementsUtility.cs:245)
UnityEngine.Experimental.UIElements.UIElementsUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr) (at C:/buildslave/unity/build/Modules/UIElements/UIElementsUtility.cs:68)
UnityEngine.GUIUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr) (at C:/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:179)

Bolt Version:
1.4.0.f11
Unity Version:
2018.3.2f1
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Skypatcher. Sorry you're having these issues.

It does sound like some kind of serialization issue. The error you posted implies the plugin failed to initialize entirely, hence why you see the Bolt setup wizard appear.

Do you get any other kind of serialization error in the console when opening the Unity project?

Does updating to the latest 1.4.1 version (which contains many 2018.3 compatibility fixes) help?

Cannot Reproduce

I unfortunately cannot reproduce this issue. Looking at the source, you should have gotten a warning in the console before this error if the project settings asset failed to load.

Let me know if you have further details or reproduction steps that could help me fix the issue.

This exact same bug appears in Unity 2019.1.0f2, Bolt 1.4.3 in both Asset Store and .NET 4 version, same stack trace and all. I cannot go past the Naming Convention setup too

Got a lot of warnings beforehand about DictionaryAsset and VariablesAsset failed to load:


This happens when Bolt has just been imported
It's similar to https://support.ludiq.io/communities/5/topics/2018-loading-dictionaryasset-variablesasset-failed-on-unity-2018 but happens in 2019

Same here on a new installation, just trying to select naming convention

Hi Robert,

It seems from this screenshot that you're getting a compilation error that might prevent Bolt or something else from building properly. The error is caused because you use the .NET 3.x version of Bolt in a .NET 4.x project. Can you fix that and see if it helps?

+1
Working on Fix

Thanks for updating the report everyone, it seems like 2019 reintroduced an issue that was long since gone.

I'll get to investigating this ASAP. In the mean time, if it's possible for you, please try using 2018.3.x.

Cannot Reproduce

So I tried reproducing this but I still cannot.

  1. Created a new blank project in 2019.1.2f1
  2. Downloaded Bolt from the Asset Store
  3. Imported the .NET 4.x package
  4. Went through the setup wizard completely

No error whatsoever. If anyone has precise reproduction steps I would really appreciate them!

I *did* encounter the issue when re-importing a project without the Library folder on a newer Unity version. Restarting Unity fixed it. Did a restart work for you two?

Created a new 2019.1 and imported Bolt from the asset store and only import the net 4.x stuff.

Got past the error I reported, so all good.

Same issue:
Cannot open two instances of the fuzzy window at once

on 2020.1.4f1 windows 10