Pending Review

Script not being detected

Josh Hanchar 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 3

Hi, I am brand new to Bolt, used to use PlayMaker years ago, and have been out of the dev game for a few years. Anyway, I installed Unity's Vector Graphics package via package manager under the light weight render pipeline, and I have a GameObject with a "SVG Image" script attached to it. It has a color property attached to that I want to change via Bolt. I have tried updating the units with the wizard, but the SVG Image script still doesn't show. Is there a way I can manually get Bolt to add a script? Thanks!

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Josh!

Things to check:

  • The type is added to the Unit Options Wizard (https://ludiq.io/bolt/manual/scripting/custom-types)
  • You hit "Generate" after adding the type and waited for it to complete
  • If it's an abstract type, make sure AOT Safe Mode is turned off in the Ludiq preferences

If none of that works, please let me know!

Tried those options..

The SVGImage.cs script is located in Library > PackageCache if that matters?

Hi Josh, sorry for the late reply, I was on holiday. 

If it's in a package, it might be included in another assembly than those included by default. In the first page of the unit options wizard ("Assemblies"), can you look in the list of options if there's anything that would look like the name of the SVG package?