Group box rename bug

babywka 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 8
  1. Create StateMachine
  2. Enter state machine state
  3. With ctrl+LMB create a new Group element 
  4. Try to rename it in Graph Inspector

    Expactation - text label become editable

    Bug - 
    Teleporting me to root of state machine
Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Cannot Reproduce

I tried reproducing the issue with your exact steps and I don't get the behaviour you described:


I am using v.1.4.1b1 but in theory nothing that could affect that should have changed since 1.4.0f10, so I don't know what could be different. Let me know if I did the steps wrong!

dont make any click after group has created on the canvas, just create the group and click title in inspector

Ok, I'll have another look with this approach.

Fixed in Beta

Got it, will fix for v.1.4.1b3. It's related to Bolt trying to give focus to the group label field, which never worked consistently anyway. I removed that code for now and the issue appears to be gone.