Cannot Reproduce

Object Variables are not supported in Nested Prefabs.

Poinball 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 7

Object Variables are not supported in Nested Prefabs.

They are automaticly deleted ... 

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):

Hi Poinball,

Are you also getting this issue on 2018.3? I'm testing from the latest 2018.3.0b12 and I can't reproduce it. Variables can get created and don't get deleted.

If you can, please provide clear reproduction steps.

Im having the same problem

Variables are being deleted out of my prefabs and crashing my scripts

also when i create a prefab the scripts associated with the object dont carry over into the prefab 

Hi DMP3, 

Can you see if my last reply in this thread actually explains your problem? From your description, it sounds like it does: https://support.ludiq.io/communities/5/topics/2656-applying-changes-to-prefabs-with-scene-references-shows-object-reference-at-index-does-not-match

Pending Review

I'll re-open and re-evaluate this, later betas & stable versions of 2018.3 seem to have changed their prefab reference handling.

Cannot Reproduce

I tried to reproduce this again in the the latest Bolt and Unity and couldn't. Object variables can be created in Nested Prefabs, whether from the Instance or from the Definition, whether in Isolation mode or in normal scene view, with or without apply overrides. Since this report is from 2 months ago, I assume something along the way (either from us or from Unity) fixed it. Closing again.