0
Unity Bug

Fatal error in GC: Too many heap sections

William Besnard 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 7

Hi! I've encountered a bug when trying to install Bolt on Unity 2018.3.0b.11, 

When generating types, the GC crashes on the step "Building unit database" - "Converting codebase to unit options" and gives the following error "Too many heap sections"

Bolt Version:
the last one downloadable on the asset store
Unity Version:
2018.3.0b.11
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi William,

Sorry you've been getting this issue. I've personally experienced it once or twice in 2018.3 as well. I wonder if it has something to do with an internal Unity change (I asked on the beta forum here). I don't know of any workaround apart from restarting Unity or rebooting your computer. Can you try that and report back?

Hi, it still appears after restarting Unity or rebooting my computer, I wonder if it's linked to the amount of RAM available: I will try on a more powerful computer tomorrow. Thanks for your support!

Hi! It still happens on this more powerful machine, even after restarting the editor. I also tried with Bolt 2.0 but without success. I did manage to import some types by unticking the "Unity Object" which lowered the number of types from around 4k to 900, and then it worked, but I obviously mainly want to get the Unity Object ones :)
Hi William,
Are you getting this issue on 2018.2.x?
From the forum post I made it seems like we're not alone and that it's a Unity 2018.3 bug.
Hi Lazlo, I will check it out tomorrow and let you know, but I'd say most likely not
Hi Lazlo,

I successfully installed Bold on 2018.2 on a very similar project (not exactly the same plugins installed, but a very similar code base) so the problem seems to come from the beta version!