0
Fixed

Prefab Isolation Mode creates infinite scene variables

Lazlo Bonin (Lead Developer) 2 years ago updated 1 year ago 11 1 duplicate
Bolt Version:
1.4+
Unity Version:
2018.3+
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

Duplicates 1

Cannot reproduce in 2018.3.0b12. If anybody gets this issue, please post reproduction steps.

I have the issue on 2018.3.0b12 with 1.4.0f7.
Repro steps:

  1. In a new scene, create an empty GO
  2. Attach a flow machine
  3. In the flow, create a SceneVariable (went for Vector3)
  4. Create a prefab out of the GO
  5. Enter prefab mode
  6. Add a GetSceneVariable unit

Description of the issue:
In the prefab mode hierarchy, many "SceneVariables" are created. These GO do not appear when the prefab is instanced in the scene (or deleted so fast I can't see them ;)



    Definitively affect performance in the editor if you leave the prefab mode open enough time to write repro steps :D 

    Workaround is to work in a scene but I like the prefab mode sooooo much! 

    Pending Review

    Hi Jalzorus, can you try updating Bolt to v.1.4.0f11, the latest version,  and confirm that you are still getting the issue?

    Download link: https://ludiq.io/bolt/download/1.4.0f11

    Working on Fix

    Nevermind, managed to reproduce. Working on fix.

    Fixed in Beta

    Fixed for v.1.4.1b2.

    +1

    This was fixed in Bolt v.1.4.1b2.

    You have to download the latest beta version from Ludiq downloads section. 

    confirm works fine for me in Bolt v.1.4.1b2.