0
Fixed

Failure to parse preview build version string

HyenaGames Dev 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 8

New Version of Unity, New Version of Bolt, and I'm still getting a very similar error. This time with a bit more info:

Unity: 2018.2.x Unity Prefabs Preview Build

Bolt: Current 1.4 version on market

If I click on Tools -> Ludiq -> About or Tools -> Bolt -> About, I get the following:

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.GUISkin.GetStyle (System.String styleName) (at C:/buildslave/unity/build/Modules/IMGUI/GUISkin.cs:312)
UnityEngine.GUIStyle.op_Implicit (System.String str) (at C:/buildslave/unity/build/Modules/IMGUI/GUIStyle.cs:443)
Ludiq.ChangelogPage+Styles..cctor () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:1842)
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for Styles
Ludiq.ChangelogPage.FormatChange (System.String change) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:1732)
System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[System.String,Ludiq.ChangelogPage+Change].MoveNext ()
System.Collections.Generic.List`1[Ludiq.ChangelogPage+Change].AddEnumerable (IEnumerable`1 enumerable) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Collections.Generic/List.cs:128)
System.Collections.Generic.List`1[Ludiq.ChangelogPage+Change]..ctor (IEnumerable`1 collection) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Collections.Generic/List.cs:65)
System.Linq.Enumerable.ToList[Change] (IEnumerable`1 source)
Ludiq.ChangelogPage..ctor (Ludiq.PluginChangelog changelog, Boolean showPluginName) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:1703)
Ludiq.ChangelogsPage..ctor (IEnumerable`1 plugins) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:1854)
Ludiq.AboutPage.CreatePages (IEnumerable`1 plugins) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:944)
Ludiq.AboutPage..ctor (Ludiq.Product product) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:931)
Ludiq.AboutWindow.CreatePage ()
Ludiq.SinglePageWindow`1[TPage].get_page ()
Ludiq.SinglePageWindow`1[TPage].ConfigureWindow ()
Ludiq.AboutWindow.ConfigureWindow ()
Ludiq.EditorWindowWrapper.CreateWindow ()
Ludiq.EditorWindowWrapper.ShowUtility () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Reflection/MemberOptionTree.cs:308)
Ludiq.AboutWindow.Show () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:1307)
Bolt.BoltProduct.HookAboutWindow () (at C:/Users/lazlo/Projects/Ludiq/Bolt.Core/Editor/BoltProduct.cs:63)


I also get the following occasionally which may be related:

Failed to parse Unity version string, falling back to 2017.4.0:
 System.FormatException: Unity version string has unexpected count of parts (4).
  at Ludiq.EditorApplicationUtility.get_unityVersion () [0x00021] in C:\Users\lazlo\Projects\Ludiq\Ludiq.Core\Editor\Inspection\MetadataDictionaryAdaptor.cs:122 
UnityEngine.Debug:LogWarning(Object)
Ludiq.EditorApplicationUtility:get_unityVersion() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/MetadataDictionaryAdaptor.cs:122)
Ludiq.EditorApplicationUtility:get_createLinearTextures() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/MetadataDictionaryAdaptor.cs:126)
Ludiq.ColorUtility:GetPixel(Color) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Windows/Sidebars/Sidebar.cs:34)
Ludiq.ColorUtility:GetPixel(SkinnedColor) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Windows/Sidebars/Sidebar.cs:46)
Ludiq.Icons:Load() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Windows/WrappedEditorWindow.cs:15)
Ludiq.LudiqCoreResources:Initialize() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Windows/WebView.cs:65)
Ludiq.PluginContainer:Initialize() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/SQLite/SQLite.cs:1523)
Ludiq.PluginContainer:.cctor() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/SQLite/SQLite.cs:1278)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


Invalid editor window Ludiq.WrappedEditorWindow
UnityEditor.EditorApplicationLayout:FinalizePlaymodeLayout()


Along with all this, my Bolt options won't save Specifically the "Update Units Automatically" setting. I turn it off. But every time I enter Play mode, it turns back on automatically, and this auto-updating is causing lag.

I've tried re-installing / re-importing Bolt. It didn't help. 

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

Hi Hyena, I split your comment into a new thread because it seems like a new issue.

There are 3 different errors here so we'll try to deal with each individually.

  1. Let's start by fixing 2 and seeing if it helps
  2. What is the exact version string of Unity? You can check that in the Unity About window or in the title bar of the editor
  3. When do you get that error from WrappedEditorWindow exactly?
  4. The options not saving could be related to this issue, which will be fixed in 2018.3 and backported to 2018.2

1& 2) Here is the Version String

2018.2.0x-ImprovedPrefabs Personal

3 & 4) Upon first opening my Project, I get these.. This makes me think you're correct about #4 being related.


If I click Tools -> Bolt -> About, I get this:

Working on Fix

I see, I'll update my version parsing code to reflect Unity's semi-semantic naming.

Fixed in Next Version

Fixed for v.1.4.0f6

Well, it seems that 1.4.6f is completely incompatible with the Prefabs Preview beta build. After importing the new package, Unity won't load bolt at all. I tried importing it over the top of the current 1.4 Bolt, and it gave me a C-Sharp-Assembly error and crashed Unity. I did a reimport-all and that didn't help. Restarted Unity and deleted the Ludiq folder, and then re-imported 1.4.6f and now I'm not getting errors, but Bolt just isn't loaded. No menu options. Nothing. I'm not sure why it's not working because I'm not getting any feedback from it. But I can't make 1.4.6f work in Unity Prefab Preview.



That's odd. If you don't even see the Tools menu items, it means your project doesn't compile, so Bolt can't load. Make sure your project compiles and it should appear and work. I unfortunately can't invest time in testing Bolt with experimental builds at the moment, sorry!