0
Answered

Correct procedure for updating both Unity and Bolt on a project?

Victory Over All 3 years ago updated 3 years ago 2

What’s the correct procedure for updating both Unity and Bolt on a project? I want to upgrade from Bolt 1.3 to 1.4 (because the new features in Bolt 1.4 look awesome!) but my project is currently on Unity 2017.3.0f3 so I need to upgrade Unity. I've tried, but I think I'm going wrong somewhere. Here's what's going on...

I backed up my project, then opened it up in 2018.2.3f1 and let Unity do it’s thing. Once that had finished converting/importing I tried to update Bolt through the Asset Store within Unity. I hit Download, then Import, but on the following window (see below) I could only select the "Assemblies" and "Bolt.Core" folders to import. Clicking the checkboxes of the other items did nothing, as did clicking the "None" and "All" buttons at the bottom of the window.


I assumed this was normal, so hit the import button, but after importing the Bolt Update Wizard did not show up. But I had a couple of errors pop up in the console. One about a "NullReferenceException" and another about 26 unit options failing to load (see screenshot below)


I waited a while but the Update Wizard didn’t show, so I tried to open the Update Wizard manually, but it does not open and just spits out the same "NullReferenceException" error in the console. I also can’t open some Bolt windows like About, sometimes receiving the same error instead.

Oh and I tried running the Bolt Setup Wizard, thinking that maybe I misunderstood something and it was that Wizard I was supposed to run, but then this happens:


Each log gives me the same "System.IO.FileLoadException: MSBuild / XBuild not found." message. This wasn't an issue before I tried updating.

I have some other assets installed in the project which are now in Unity’s Package Manager (ProBuilder/ProGrids/PolyBrush and Cinemachine) but I’m not sure if they would cause any conflicts/problems.

I’m pretty sure this is User Error™ so I’m posting it as a question rather than a bug. Restarting Unity doesn't help neither. Anyone know where I'm going wrong? Any advice is massively appreciated!

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
+1
Answered

Hi Victory!

Updates are always tricky, even if I try to make the process as seamless as possible.

I'll try to adress every issue individually:

  • Checkboxes not working: I believe the Unity package import wizard only lets you check items that actually changed. It's likely that other items in the package were identical, so Unity didn't let you check those boxes.
  • Units failed to load: This is a warning because it is harmless. You can follow the instructions in the warning itself (rebuilding your unit options) to get rid of it.
  • Generate documentation: The error log after MSBuild / XBuild not found should also give you a download link for MSBuild. Just follow it and install it on your machine. Note that documentation is not required for Bolt to run, so in the mean time, you can safely skip that step in the wizard.
  • NullReferenceException and wizard not opening: I've had this issue happen a few times on major updates. Usually, it can be resolved by either entering and exiting play mode, or by restarting Unity.

Let me know if that helps!

Hey Lazlo,

Thank you so much for taking the time to reply! It was a huge help because... *drumroll*

TADA!! Yes! It turns out that I needed to restart and then enter play mode before I could open the Update Wizard. I'd only tried restarting before and it didn't cross my mind that I just needed to hit that play button.

The MSBuild / XBuild errors are still there when generating documentation, which wasn't an issue before updating Unity or Bolt, but like you've already said, it's not a major problem! There's no link in the error log, but I'm sure it won't be difficult to track down.

Thanks again for your help!

Cheers,
Jason