0
Cannot Reproduce

Bolt crashes when project is reopened

methuzelah1 4 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 5

Hi,

This occurred using Bolt v1.3.1 (Ludiq Core)/1.3.0 (rest).  I am on Unity 2018.1.6f1.

Bolt doesn't seem to start up correctly.  A project that was previously using Bolt successfully failed to load Bolt after exiting Unity and opening again.  The Bolt set-up wizard appears again when the project re-opens.  If I try to go through the wizard again, Bolt hangs.  If I skip the wizard set-up, then I cannot access any flows or other Bolt components. 


I received the following message when I tried to generate documentation through the wizard.

System.IO.FileLoadException: MSBuild 14.0 not found. Download and install it from:
https://www.microsoft.com/en-us/download/details.aspx?id=48159
  at Ludiq.Paths.get_builder () [0x00021] in C:\Users\lazlo\Projects\Ludiq\Ludiq.Core\Editor\Utilities\Paths.cs:160
  at Ludiq.DocumentationGenerator.GenerateDocumentation (System.String projectPath) [0x00095] in C:\Users\lazlo\Projects\Ludiq\Ludiq.Core\Editor\Documentation\DocumentationGenerator.cs:32
  at Ludiq.GenerateDocumentationPage+DocumentationGenerationStep.Update () [0x00028] in C:\Users\lazlo\Projects\Ludiq\Ludiq.Core\Editor\Windows\GenerateDocumentationWindow\GenerateDocumentationPage.cs:277


When I tried importing the newest v1.4, I received the following error message:

The import failed and Bolt remains on 1.3.


This has happened on two test projects, and prohibits my use of the tool, essentially losing my work.  Please note that I have also written some sample custom units to test (code copied below).  I don't know if this is causing any sort of corruption/fail, but the test custom unit did work fine before the crash.  Apologies, the spacing changed when I pasted in the code.


Thanks for your help.

using System.Collections;


using System.Collections.Generic;


using UnityEngine;


using Ludiq;


using Bolt;




 


 



public class InOutUnitTest : Unit {





[DoNotSerialize]



public ControlInput input;




[DoNotSerialize]



public ControlOutput output;




[DoNotSerialize]



public ValueInput valueIn;




[DoNotSerialize]



public ValueOutput valueOut;


protected override void Definition()




{



input = ControlInput("in", new System.Action<Flow>(Enter));


valueIn = ValueInput<float>("valueInTest");


valueOut = ValueOutput<float>("valueOutTest", ReturnFloat);


output = ControlOutput("out");




}



private void Enter(Flow flow)




{




flow.Invoke(output);



}



private float ReturnFloat(Recursion valueout)




{



float value = valueIn.GetValue<float>();




value *= 3;



return value;




}


 


}




Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
GOOD, I'M SATISFIED
Satisfaction mark by methuzelah1 3 years ago
Pending Review

Hi methuzelah, sorry you're experiencing these issue.

1. Failing to generate documentation:

Just follow the link described in the error message to install the missing software:

https://www.microsoft.com/en-us/download/details.aspx?id=48159

2. sqlite3.dll failed to copy: 

Try unchecking sqlite3.dll in the import dialog before hitting Import!

3. Unit failure:

It's hard to tell without any error message!

4. No options:

If you really can't go through the setup wizard, try skipping it and then using Tools > Bolt > Build Unit Options.

Hi Lazlo,

Since this was a test project, I am going to move on, but wanted to reply.  Overall the steps above did not seem to resolve the issue, and I suspect a corrupted file.  The versions I have from before writing custom units work fine.  The crashes only occur with the versions made after Custom units were built, though I don't know why this would potentially corrupt files.

1.  This part loaded fine, and error did not seem to repeat.

2.  I was unable to do this.  I couldn't check/uncheck options when I tried importing.

3.  No error message came up beyond what was reported above.

4.  Already tried this step, and it did not resolve the problem - Bolt still wasn't working:  Previously working custom units and standard units simply did not appear in Flow Graphs, no units appeared in the fuzzy finder, and I couldn't run the game.

Here is a link to the game files, in case you're interested: [SNIPPED] Note that since this was a test for a platformer game not all the assets are nice and neat.  However all the Ludiq files are there.

Thanks.

Hi methuzelah,

I will try reviewing the project and see what went wrong.

In the future, do not share entire projects that contain the Ludiq folder. Doing so, you are publicly redistributing the Bolt asset, which is illegal under the Asset Store EULA.

sorry about that, meant to only share with you.  I removed the public access.

Cannot Reproduce

Hi methuzelah, 

Just updating this to let you know I'm fixing this as part of the extractor update in v.1.4.1, which should eliminate any remaining startup/database error.

Regarding the setup wizard restarting every time, it is related to this issue, which has been confirmed to be a Unity bug and will be fixed in Unity 2018.3 and backported to 2018.2.

Thank you so much for your patience, hope your other (non-test) projects are going well!

(Closing as "Cannot reproduce" just because I don't have a specific status for each issue reported)