On button Click not triggered in build, Bolt 1.4 beta 2

ShamanFu 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 13

Hi I create a simple gym of my bug.

just a button that change text. in the editor everything work, in a build of that, it don't work.

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Satisfaction mark by ShamanFu 3 years ago
Pending Review

Hi ShamanFu,

Please do not share entire project folders, because you're redistributing the Bolt plugin publicly with it.

I downloaded it and removed it from your post.

Can you give me more information about the build? For which platform is it? Did you use AOT Pre-Build?

I've been able to reproduce the issue and am currently looking for the cause.

oups, I will not repeat this mistake. sorry and thx for looking into this bug.  

I don't use AOT from what I know. could you tell me if I can change something in my player setting that may help?

Or tell me the setting you use for you Bolt v.1.4.0 Beta 3 (.NET 4.x)


Thanks for chiming in Cocell, although this does seem like a bug, and it's kind of hard to track down. I'm looking into it today, it's the last thing before I can push 1.4 to stable I think.

Fixed in Beta

Fixed for stable. This was a problem with the Unity main thread detection during Awake/OnEnable... tricky bug!

Hi, I have the same problem with Bolt 1.4.0f5. I use Unity 2017.4.9f1.

My build is for Windows platform.


Hi Florian, sorry you're having an issue.

  • Are you running AOT Pre-Build before building (Tools > Ludiq > AOT Pre-Build)?
  • Are you targetting the IL2CPP backend? Bolt is incompatible with the UWP runtime.

Actually the build is for standalone Windows (I run AOT Pre-Build in case), I tried recompile multiple time but it still not working. Which is weird is that rarely when I start the game it's working and when I restart it's not working anymore. Maybe I can share my project with you to help understand the issue ?

Sure, but please start a separate issue or send us a private support ticket (do not post the project with the Bolt asset publicly). This issue here was resolved a month ago.