0
Fixed

Terminal Error - Unity 2018 b2.1 and Bolt TMP not found errors and Error drawing VariableDeclarationInspector.

Kev Sutherland 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 4

After a fresh install of Unity 2018 b2.1 and then Bolt 1.3 I'm getting lots of errors (nasty red ones) telling me that several provider files for TMPro (I'm assuming TextMeshPro) are missing. Though I didn't install TMPro it seems that it's now part of the default package installation in the latest beta and therefore it gets install ed automatically.


The red errors I can handle but unfortunately bolt will not run in this state .


Amongst other tins the Variables inspectors down work and instead I see the Error drawing VariableDeclarationInspector.


It's repeatable and terminal unfortunately. I guess it serves me right for using latest builds : ) 


thanx in advance for any help : ) 

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

Forgot to mention this error too same steps but after install of bolt and setup process.

EndLayoutGroup: BeginLayoutGroup must be called first.
UnityEngine.GUILayout:EndScrollView()
Ludiq.Page:DrawContent() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Reflection/MemberOptionTree.cs:132)
Ludiq.Wizard:OnGUI()
Ludiq.WrappedEditorWindow:OnGUI()
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Pending Review

Hi Kev,

Thanks, the Unity QA team actually reached out to me to warn me that beta 2 introduced a breaking change that prevents the variable inspector from drawing. I will fix it for v.1.4.

NP, happy to help, awesome product BTW : )