Cannot Reproduce

Error drawing ListInspector after 2018.2.0b1 update

Fatih 3 years ago updated by Rob Murray 3 years ago 22

I got this error after I installed Unity 2018.2.0b1. Should I revert back to 2017?

Bolt Version:
Unity Version:
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Fatih,

Can you click the warning you see in the inspector and paste the stack trace that gets logged to the console?

Just for information,

I installed 2017 and it solved everything. I think 2018 has issues in itself because even it has no standart assets download with it. May be the problem was it but not sure.

Any way 2017 has no issues. Stable version has no problem, problem solved.

The stack trace was provided a month ago, what other details are required?

The error "Error drawing ListInspector" appears in Bolt Setup Wizard, page Assemblies.

Stack trace:

NullReferenceException: Object reference not set to an instance of an object
Ludiq.ReorderableList.ReorderableListControl.PrepareState (Int32 controlID, IReorderableListAdaptor adaptor)
Ludiq.ReorderableList.ReorderableListControl.Draw (Rect position, Int32 controlID, IReorderableListAdaptor adaptor, Ludiq.ReorderableList.DrawEmptyAbsolute drawEmpty)
Ludiq.ReorderableList.ReorderableListControl.Draw (Rect position, IReorderableListAdaptor adaptor) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Utilities/SearchUtility.cs:29)
Ludiq.MetadataCollectionAdaptor.Field (Rect position, UnityEngine.GUIContent label) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Meta/Metadata.cs:678)
Ludiq.ListInspector.OnGUI (Rect position, UnityEngine.GUIContent label) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Plugin/LudiqCore.cs:27)
Ludiq.Inspector.Draw (Rect position, UnityEngine.GUIContent label) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Meta/IndexMetadata.cs:24)
Ludiq.Inspector:Draw(Rect, GUIContent) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Meta/IndexMetadata.cs:24)
Ludiq.LudiqGUI:Inspector(Metadata, Rect, GUIContent) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Reflection/NamespaceOption.cs:15)
Bolt.AssemblyOptionsPage:OnContentGUI() (at C:/Users/lazlo/Projects/Ludiq/Bolt.Flow/Editor/Windows/AssemblyOptionsPage.cs:48)
Ludiq.Page:DrawContent() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Reflection/MemberOptionTree.cs:132)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Prior to this error there is a warning "Assembly: 'E:/Unity/Test/Assets/Ludiq/Assemblies/Ludiq.Core.Editor.dll' uses obsolete Unity API (UnityUpgradable)".

More errors:

Variables window (in every var tab): "Error drawing VariableDeclarationsInspector".

Graph Inspector (in every Input/Output): "Error drawing ListInspector".


Same error with 2018.2.0b6, has any progress been made on a resolution or work around?


This seems like a new issue introduced in Unity 2018.2. It will be fixed for v.1.4.

Much appreciated, I will test tonight after I install 2018.2.0b7, which was released a day or so ago. 

Still getting this error in 2018 2.6f1 and Bolt 1.4. Also error drawing variable inspector (I can't make a variable!)

I'm still getting this error with the latest build of Unity.Can you please fix this as soon as possible or I will stop using Bolt as I find it very buggy and there are better options available.I will also lodge a complaint with Unity as to why they seem to be favouring this plugin as opposed to others.

Pending Review

Hi everyone,

I'm downloading the latest version of Unity right away to see if they changed anything in their code that would affect the list inspector. I fixed the issue in 2018.2.0, but maybe there's a new one in 2018.2.6.

Hi Richard, hi Rob!

I downloaded Unity 2018.2.6f1 and I have no issue with the inspector:

Can you please paste the exact error log you are getting when you click on the "Error drawing inspector" warning?

Hopefully here are some screengrabs...

Can you please paste the exact error log you are getting when you click on the "Error drawing inspector" warning?

I'm getting this alert in my log continually when using Bolt with Unity 2018.2.7f1.

Inspector block metadata mismatch.
Ludiq.Inspector:EndBlock(Metadata) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Meta/Metadata.cs:89)
Bolt.FlowGraphEditor:OnGUI(Rect, GUIContent) (at C:/Users/lazlo/Projects/Ludiq/Bolt.Flow/Editor/FlowGraphEditor.cs:89)
Ludiq.Inspector:Draw(Rect, GUIContent) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Meta/IndexMetadata.cs:106)
Ludiq.LudiqGUI:Editor(Metadata, Rect) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/SerializedProperties/SerializedPropertyProviderProvider.cs:42)
Ludiq.GraphInspectorWindow:OnGUI() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Graphs/Editor/Windows/GraphInspectorWindow.cs:149)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

I apologize :) Updated and no errors. Thanks for the Update Wizard!

Finally managed to get it all working by downloading everything fresh and installing in a new folder.