0
Answered

Rebinding CONTROL SHIFT shortcut

Jorikito 4 months ago updated by Aaron Loften 2 months ago 2

Hey guys, Peek's default shortcut for creating a new gamobject at the cursor location is CONTROL + SHIFT and clicking somewhere. Now control shift is also the shortcut for removing only the selected detail asset from the terrain. Peek's shortcut seems to be blocking this one though, I cannot seem to find either of these to remap in the shortcut manager.

Unity Version:
2020.1.6f1
Peek Version:
1.1.9 / 2.0.0a5
Answered

Hi Jorikito,

Sorry for the very late reply.

In case you haven't figured it out by yourself by now, shortcuts can be rebound starting from Peek v.1.3. Simply update to get the new options in the Peek Preferences:

According to your unity post forum....

This is ONLY available in peek version 1.3.2 and higher. If your package manager isnt showing the proper version(or if it appears to show like you have BOTH versions...dont ask) you should follow the instructions here for deleting the base files so you can remap your keys and what not...

https://forum.unity.com/threads/package-manager-not-showing-latest-version-from-asset-store.791718/

Long story short...
1. Delete Peek from your unity version.
2. go to... %APPDATA%\Unity\Asset Store-5.x\PUBLISHER\Ludiq\PACKAGE.unitypackage and delete it
3. go back to unity package manager and hit the little refresh thing in the bottom corner. I believe it also refreshes when looking for "more packages".
4. redownload.

Man.....this has been driving me crazy for weeks.... Love this tool. sucks when you have to choose between great tools due to conflicts.