0
Fixed

Preferences missing | Sprite thumbnails overlap in list view

Kristina Waldt 7 months ago updated by Lazlo Bonin (Lead Developer) 7 months ago 9

Hello,

I am missing the preferences option for Peek. Since I had them when I first installed Peel (1.1.8), I assume it happened after the upgrade to 1.1.9.

I was trying to see if Peek is responsible for this behaviour (by drawing the buttons):

(I'm in list view in the project window.)

The images are drawn over each other with a slight offset. It also happens with non-transparent sprites, but it's less noticeable there.

Best Regards,
Kristina

Unity Version:
2019.4.8f1
Peek Version:
1.1.9
GOOD, I'M SATISFIED
Satisfaction mark by Kristina Waldt 7 months ago
Need More Information

Hi Kristina,

Thanks for the report and sorry you're experiencing these issues.

Are you getting any console error upon opening the project that seem related to Peek? I can't reproduce the preference item not showing up locally.

Regarding the icons, that's an issue I've encountered when using version control extensions for Unity that seem to change the placement of hierarchy icons when adding their overlay. I'll need to find a reliable fix for it, but in the mean time, if you manage to get your preference pane back, you should be able to disable Preview Icons.

Hi,

there aren't any errors. I created a new project in 2019.4.8f1 and added only Peek 1.1.9 to rule out that it's an incompatibility with other assets. There still aren't any preferences. (I also upgraded to 2019.4.9f1 but with no success.)

I didn't have that issue with the previous version of Peek, but it's a bit strange if you can't recreate it.

I've just imported Peek into my project and ran into the same issue.

Steps to reproduce on a new project:

  • Create project with Unity 2020.2.0b2 (3094) with the URP template.
  • Import Peek 1.2.0f1 from the package manager.
  • Complete setup wizard.
  • Look at project settings.
+1

Oh actually, it's working in the new project now. 

I looked at the Peek asset store page again and wanted to try the Tabs feature. So after maximizing the scene view and clicking on the preferences/project settings icon the settings window opened and the Ludiq entry was there.

Somehow it didn't work at all the first time even switching active windows in Unity and now it does work.

I've also reproduced this in my other project. Simply maximizing the scene view somehow fixed the problem.

The fix worked for me too, thanks! Maximised and un-maximised the scene view, and now I have the preferences.

Pending Review

Thanks for the additional reproduction steps! I'll try reproducing this on my end and figure out what's going on. :)

+1
Working on Fix

Hi Kristina,

I found a case where Peek would not display its preference panels if they were already open during the first frame after an assembly reload (recompiling, entering play mode, etc.). I've fixed this for the next version.

I'm also investigating the icon hierarchy offset issue right now.

+1
Fixed (Unreleased)

Hi Kristina,

I've found and fixed the cause of the icon offset in the project window. Both fixes will make it into the next release.