Not a Bug

Cannot open two instances of the Fuzzy window at once

Andrew Scott 1 year ago updated 1 year ago 14

So I am in 2D, created a Grid of Game Objects with children (10x10) and then created a prefab of one of these. Made no changes to the prefab, if that matters and then selected all 100 of those game Objects, then proceeded to replace the normal game objects with the prefab.

Now while it worked, I got 99 errors in the console saying

InvalidOperationException: Cannot open two instances of the fuzzy window at once.
Ludiq.PeekCore.FuzzyWindow.Show (UnityEngine.Rect activatorPosition, Ludiq.PeekCore.IFuzzyOptionTree optionTree, System.Action`1[T] callback) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/Fuzzy/FuzzyWindow.cs:299)
Ludiq.PeekCore.LudiqGUI.FuzzyDropdown (UnityEngine.Rect activatorPosition, Ludiq.PeekCore.IFuzzyOptionTree optionTree, System.Object selected, System.Action`1[T] callback) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/LudiqGUI.cs:2512)
Ludiq.Peek.Replacer.Open (UnityEngine.GameObject[] targets, UnityEngine.Rect activatorPosition) (at Assets/Ludiq/Ludiq.Peek/Editor/Creator/Replacer.cs:24)
Ludiq.Peek.GameObjectOperations.Replace (UnityEngine.GameObject[] targets, UnityEngine.Rect activatorPosition) (at Assets/Ludiq/Ludiq.Peek/Editor/Context/GameObjectOperations.cs:145)
Ludiq.Peek.CreatorMenuIntegration+<>c__DisplayClass9_0.b__0 () (at Assets/Ludiq/Ludiq.Peek/Editor/Creator/CreatorMenuIntegration.cs:76)
Ludiq.Peek.GuiCallback.Process () (at Assets/Ludiq/Ludiq.Peek/Editor/Integration/GuiCallback.cs:35)
Ludiq.Peek.GuiCallback:Process() (at Assets/Ludiq/Ludiq.Peek/Editor/Integration/GuiCallback.cs:39)
Ludiq.Peek.HierarchyToolbars:OnHierarchyItemGUI(Int32, Rect) (at Assets/Ludiq/Ludiq.Peek/Editor/Toolbars/Integrations/HierarchyToolbars.cs:26)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Unity Version:
Peek Version:

I have no idea why my comment was not listed.

I DO NOT USE BOLT, so therefore it was not a misplaced bolt report.

What my comment should have said, was that I haven't seen this for since you said you fixed it, but I haven't done enough Unity development in the last few months to confirm or deny it as being fixed.

Satisfaction mark by Andrew Scott 1 year ago

Any solution for this issue?

Fixed (Unreleased)

Hi Andrew, Ganeshbabu,

Thank you for the bug report and sorry about the issue and delay in support.

I have found the cause of the issue and will have a fix in place for the next version.

In the mean time, rest assured that the error is benign and will not cause any issue in functionality.

You can avoid it for now by using the shortcut (Alt+R) to replace instead of the context menu.


I am also experiencing this issue on mac unity 2020.1.of1
Any updates on a fix?

lots of people reporting this https://forum.unity.com/threads/bolt-mac-cannot-open-two-instances-of-the-fuzzy-window-at-once.938465/


Sadly the issue is still there! Cant use Bolt on my Mac with latest Unity 2020.1.of1

Still happening in 2020.1.2f1, and I'm not even using Bolt.

Pending Review

Hi everyone,

Sorry for the delay on this. I'll re-open the issue as it's obviously still occurring for many of you.

Can you provide more details about the reproduction steps? (What you're doing when the error appears)

Are they the same as OP's report or have they changed?

Need More Information

I tried reproducing this issue using OP's reproduction steps in Unity 2020.1, but no error occurs.

I'll mark this thread as NMI until someone can provide their reproduction steps. Thanks!


I'm trying bolt for the first time today (great tool for now).

I just have an error like OP on Unity 2020.1.5f1 Personal. Error appears when I stop to search an item and decide to close the search window popup in graph scene.

Error here:

InvalidOperationException: Cannot open two instances of the fuzzy window at once.
Ludiq.FuzzyWindow.Show (UnityEngine.Rect activatorPosition, Ludiq.IFuzzyOptionTree optionTree, System.Action`1[T] callback) (at C:/Users/RohitMoni/Documents/Repos/bolt/Package/Ludiq.Core/Editor/Interface/Fuzzy/FuzzyWindow.cs:229)
Ludiq.LudiqGUI.FuzzyDropdown (UnityEngine.Rect activatorPosition, Ludiq.IFuzzyOptionTree optionTree, System.Object selected, System.Action`1[T] callback) (at C:/Users/RohitMoni/Documents/Repos/bolt/Package/Ludiq.Core/Editor/Interface/LudiqGUI.cs:1477)
Bolt.FlowCanvas+<>c__DisplayClass15_0.b__0 () (at C:/Users/RohitMoni/Documents/Repos/bolt/Package/Bolt.Flow/Editor/FlowCanvas.cs:228)
Ludiq.GraphWindow.OnGUI () (at C:/Users/RohitMoni/Documents/Repos/bolt/Package/Ludiq.Graphs/Editor/Windows/GraphWindow.cs:648)
UnityEditor.HostView.InvokeOnGUI (UnityEngine.Rect onGUIPosition, UnityEngine.Rect viewRect) (at <6d0b5326886a4f0e8ed4ea356b37330b>:0)
UnityEditor.DockArea.DrawView (UnityEngine.Rect viewRect, UnityEngine.Rect dockAreaRect) (at <6d0b5326886a4f0e8ed4ea356b37330b>:0)
UnityEditor.DockArea.OldOnGUI () (at <6d0b5326886a4f0e8ed4ea356b37330b>:0)
UnityEngine.UIElements.IMGUIContainer.DoOnGUI (UnityEngine.Event evt, UnityEngine.Matrix4x4 parentTransform, UnityEngine.Rect clippingRect, System.Boolean isComputingLayout, UnityEngine.Rect layoutSize, System.Action onGUIHandler, System.Boolean canAffectFocus) (at :0)
UnityEngine.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, UnityEngine.Matrix4x4 worldTransform, UnityEngine.Rect clippingRect, System.Action onGUIHandler, System.Boolean canAffectFocus) (at :0)
UnityEngine.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, System.Action onGUIHandler, System.Boolean canAffectFocus) (at :0)
UnityEngine.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, System.Boolean canAffectFocus) (at :0)
UnityEngine.UIElements.IMGUIContainer.SendEventToIMGUIRaw (UnityEngine.UIElements.EventBase evt, System.Boolean canAffectFocus, System.Boolean verifyBounds) (at :0)
UnityEngine.UIElements.IMGUIContainer.SendEventToIMGUI (UnityEngine.UIElements.EventBase evt, System.Boolean canAffectFocus, System.Boolean verifyBounds) (at :0)
UnityEngine.UIElements.IMGUIContainer.HandleEvent (UnityEngine.UIElements.EventBase evt) (at :0)
UnityEngine.UIElements.EventDispatchUtilities.PropagateEvent (UnityEngine.UIElements.EventBase evt) (at :0)
UnityEngine.UIElements.MouseEventDispatchingStrategy.SendEventToRegularTarget (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.BaseVisualElementPanel panel) (at :0)
UnityEngine.UIElements.MouseEventDispatchingStrategy.SendEventToTarget (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.BaseVisualElementPanel panel) (at :0)
UnityEngine.UIElements.MouseEventDispatchingStrategy.DispatchEvent (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel iPanel) (at :0)
UnityEngine.UIElements.EventDispatcher.ApplyDispatchingStrategies (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel, System.Boolean imguiEventIsInitiallyUsed) (at :0)
UnityEngine.UIElements.EventDispatcher.ProcessEvent (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel) (at :0)
UnityEngine.UIElements.EventDispatcher.Dispatch (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel, UnityEngine.UIElements.DispatchMode dispatchMode) (at :0)
UnityEngine.UIElements.BaseVisualElementPanel.SendEvent (UnityEngine.UIElements.EventBase e, UnityEngine.UIElements.DispatchMode dispatchMode) (at :0)
UnityEngine.UIElements.UIElementsUtility.DoDispatch (UnityEngine.UIElements.BaseVisualElementPanel panel) (at :0)
UnityEngine.UIElements.UIElementsUtility.UnityEngine.UIElements.IUIElementsUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr, System.Boolean& eventHandled) (at :0)
UnityEngine.UIElements.UIEventRegistration.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr) (at :0)
UnityEngine.UIElements.UIEventRegistration+<>c.<.cctor>b__1_2 (System.Int32 i, System.IntPtr ptr) (at :0)
UnityEngine.GUIUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr, System.Boolean& result) (at <2500dd078a544a69b6c923861af6cd15>:0)

Thank you for your work and have a nice day !

Note that this is the Peek support forum, not Bolt. We do not provide support for Bolt anymore since the Unity acquisition.

i know it might be sad but as i said in the forum we'd move and stay on LTS version (where this bug doesn't exists)

Note that this is the Peek support forum, not Bolt. We do not provide support for Bolt anymore since the Unity acquisition.

Not a Bug

From my understanding this is a misplaced Bolt bug report, closing this for now.

Hi Andrew, 

Re: your satisfaction remark: I had fixed this bug in Peek in June, as per my comment above, as I had found a cause for it (replacing with multiple objects selected). I can no longer reproduce that specific issue and you had not commented any further, so I assumed it was fixed. All the other further reports on this thread referred to Bolt, hence why I closed it.

If you still experience this issue within Peek, please let me know and I will gladly reopen it.


Yes, and I had commented about this a week ago and for some reason, it went missing. My only complaint with the ticket being closed was how it was labelled as a misplaced bolt bug.

What I did say a week ago, was that I have not seen or experienced this issue since you stated you had fixed it, even though I have not done much Unity development since reporting this, I had specifically pulled a day aside to try to duplicate it and couldn't.

For me, the bug appeared to no longer be there.