Cannot Reproduce

Asset missing error message after installing Peek Version 1.1.1

Rachmaninow 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 3

Right after install into a large project with many app store components installed under MacOS and

Unity 2019.2.0f1

the following message appears in the console:

A tree couldn't be loaded because the prefab is missing.
Ludiq.PeekCore.Icons:OnProjectItemGUI(String, Rect) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/Icons/Icons.cs:47)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Seems to be missing some icon for the UI?

The app seems to be working alright though at first sight. Even though the error is flagged I still can run my application so this does not seem to urgent so far.

Unity Version:
Peek Version:

The message reappeared again today only to vanish again... I cannot reproduce it so I will holler if I find something.

Until then many thx

Satisfaction mark by Rachmaninow 2 years ago
Pending Review

Hi Rachmaninow,

Sorry you're experiencing this issue. Is this the full stack trace? It seems to be missing some lines.

Also, do you still get this error after restarting Unity?

Hi Lazlo,

no sweat ;-)

Funny... after the first restart the issue remained....after a second restart that one disappeared and I got some other weird messages about a socket not being available or already taken... This even with a completely empty project.

Then I got an update request for MacOS and after doing that update all seems ok again... no more messages.

Maybe there was a collision of some sort with background activities of the OS....

Anyway you can close this ...and thx for the quick reply. :-D



Cannot Reproduce

Hm odd, Peek definitely doesn't have anything to do with that socket thing! ;) Glad it worked out in the end, closing.