Editor Crashes Megathread (Send us your logs!)

Lazlo Bonin (Lead Developer) 2 years ago updated 2 years ago 35 1 duplicate

Some users have been reporting some instability / crashes. These are full editor crashes that bring up the error reporter, not console errors.

Unfortunately, we don't have enough information to debug. 

We ask users to send us the debug files that Unity generates for the editor when crashing:

  • Editor.log
  • Error.log
  • crash.dmp

They can be found here:


Sometimes, inside the logs, there seems to be no link to Peek or Ludiq at all. However, we're pretty sure something in our plugin is causing it. In those cases, if you see nothing Peek/Ludiq related, please submit the bug report to Unity. This is the best way for them to investigate and debug the internals of what's happening. Also, please link back to your Unity report here so we can follow up and look for consistency across them.

Thank you and sorry for the inconvenience!

Unity Version:
Peek Version:

Duplicates 1

I have experienced quite a few times that dragging and dropping causes crashes


I'm continuing to investigate this, but please do comment and let me know which operation caused a crash for you, it might help me isolate the cause!

I was at first reluctant to uninstall Peek from my project. I did however, stop using its functionality, thinking that I would prevent Unity from crashing, but even without using any of Peek's features, Unity kept crashing. I know you asked for specific operations but I am guessing the opposite could be just as relevant


Hi Guillermo,

I'm very sorry you experienced a crash, I hope you didn't lose any work.

Thank you for the detailed report, the stack trace points me in a direction I can investigate. I'll get back to you once I can do some more testing.

Hi! some update about this? I want to use this amazing tool

Hi Guillermo,

I'm looking into it now. I can see exactly where it's coming from in the source from the stack trace, but I can't reproduce it, so I can't test out fixes and see if they work. Is there a specific condition in which you see the crash occur?

The best way for us to debug these hard crashes is the log files that Unity generates for the editor:

  • Editor.log
  • Error.log
  • crash.dmp

They can be found here:


If ever you get a hard crash, please upload these files, otherwise we can't assist in fixing them.


As a workaround, if you encounter this specific crash frequently, you can modify the following:

File: Probe.cs

Method: SetupHighlight


        private static void SetupHighlight()
            if (highlightMaskMaterial == null)
                highlightMaskMaterial = new Material(Shader.Find("Ludiq/Editor/ProbeHighlightMask"));

            if (highlightEffectMaterial == null)
                highlightEffectMaterial = new Material(Shader.Find("Ludiq/Editor/ProbeHighlightEffect"));
                highlightEffectMaterial.SetColor("_Color", new Color(1, 0.5f, 0).WithAlpha(0.5f));
                highlightEffectMaterial.SetColor("_ChildColor", Color.blue.WithAlpha(0.5f));

You will lose the proper probe highlight colors from your Unity preferences (which we had to fetch via reflection, which seems to be causing the crash), but it should prevent that specific crash.

Thanks!! I will try it. I love Peek (I need use more but I love it)

I have this too

Invalid GUIClip stack popping

Ludiq.GraphWindow:OnGUI() (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Graphs/Editor/Windows/GraphWindow.cs:570)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

GUI Error: You are pushing more GUIClips than you are popping. Make sure they are balanced.
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr) (at C:/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:179)


That's a separate Bolt compatibility issue that has been fixed in Bolt v.1.4.7.

Hi Mike,

Thanks for the logs. Unfortunately I don't see anything Peek or Ludiq related in there. Usually the Error log is more detailed. It should be in the same folder, but if it isn't, I don't know why.

In those cases, please also submit the bug report to Unity, maybe they'll be able to debug more with the native dump.



Unity Version 2019.3.0b8
Peek Version 1.1.3

Crashes all the time when compiling scripts. Unity 2019.2.11 + Peek 1.1.4


Hi Manuel,

Thanks for the logs and sorry about the crash. Can I ask if you also had a crash dump file available?

Or even better, could you please send us your project to support@ludiq.io if it happens every time when recompiling? We can't reproduce the issue here, so if we could it would be much easier to fix.

I can't as it is the work project. But i will try to reproduce it in other project

Hey everyone,

Investigating this further, the 2 reported crashes where I could find a link to Peek were:

  • Probe.ProgramHighlight, where we access the internal SceneView.kSceneViewSelectedChildrenOutline
  • TabTool.SaveWindowPosition, where we access the internal window.m_Parent.window.position

In both of these cases, we use C#'s new dynamic keyword to access internal Unity API needed for our deep integration in the editor.

However, the crash logs (Editor.log and error.log) don't give me enough information to know exactly what's going wrong. I think the managed stack trace is getting confused by the dynamic keyword.

After some research, I found that I can debug the native crash dump files (crash.dmp) in Visual Studio with Unity's public symbols table. But to try that, I need you to also upload the crash.dmp file.

Also, if anyone has 100% reproduction, anything that causes a crash all the timeI would really appreciate if you could post either your exact steps + environment (OS, versions, etc.) OR send us your project to support@ludiq.io.

Currently, I can't reproduce the crashes consistently here, so I can't know if any fix I make actually works.

I am not sure what version of Unity these crashes are related to, but in Unity 2019.3.0b9 (not tried b10 as yet) I am seeing crashes about 20-30 times a day.

When it occurs for me, is when I am switching from another application (usually Visual Studio) and back to Unity 2019.3.0b9 and even if I switch to Unity and quickly switch to another Application, using Alt Tab.

Hi Andrew,

Thanks for the info and sorry you're also experiencing these crashes. Unfortunately that's not something I'm able to consistently reproduce, but whenever you get another crash, please upload the log and dump files so I can have a look!

(In my experience, bugs are hard to find but easy to fix. Once we know why that's happening, it should be fast to correct!)

Where would the dmp file be, I don't see it in the path suggested at the top.

According to Unity docs it should be there, but otherwise you should see the path in the Unity Crash Reporter dialog at the bottom, in the files it would send to Unity. Let me know if it's there and different from the one I found in the docs, so I can update the path here.

Will have to wait for it to crash again, but the logs where there, just no dmp file.

Hi everyone,

I'm pushing v.1.4.5 with tentative fixes for the 2 reported causes of the crashes. I'm not sure if this will help as I cannot reproduce them locally, but it could.

Available here and soon on the UAS: https://ludiq.io/peek/download/1.1.5

Tried going there, but it asks me to sign in and when I do, tells me I am invalid.

To enable access to downloads from the Ludiq website, you need to link your Asset Store invoice number in your Ludiq account: http://ludiq.io/account

Is the forum account a separate account?

Unfortunately yes, I couldn't get the UserEcho API to play nicely with our own. Sorry!

EDIT: But Peek 1.1.5 is also available on the Asset Store now: https://assetstore.unity.com/packages/tools/utilities/peek-149410

no problem, that is why I was getting confused then.

BTW I download the update 1.1.5 and I think the crashes I was having maybe fixed, will let you know if it does happen. But the one thing I know happened every time right before it did crash, was the windows I had open like the hierarchy, console and game window in Full Scene view. Would disappear and come back and that is no longer happening for me.

Need More Information

Hi everyone, 

I didn't hear any feedback about this since v.1.1.5, did anyone experience a crash after the update?

I posted above, saying that I am no longer crashing.



Seeing as I got no other report of crashing for the last month, I'll assume the fixes worked and will mark this as fixed.