0
Not a Bug

Backup useless without getting older version of Bolt

Mountblanc 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 5

During the update wizard process. I was asked if i wanted to make a backup. So i did. But now the wizard failed I restored the backup only to find the update wizard again.

I can't go back to old version as the 1.2.0 version I can't download anymore at the asset store. So now i am stuck between versions.

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

Try deleting Bolt completely, close and reopen Unity and download from asset store.

Pending Review

Hi Mountblanc,

Sorry you're having this issue. Backups are a full copy of your Assets folder, so they should include the Bolt version that was present when you created the backup. What error do you get in the Update Wizard after?

Hi Lazio,

The problem it seems is that I used V1.2 then downloaded and installed the update from the asset store window in Unity itself. Then came the update wizzard. That made a copy of the Assets folder with the new Bolt update already in place (sort of) so restoring the backup just gave me back the wizard again, The error it gave when updating I made the second bug rapport for.

Bug rapport wizard update procedure

Hi Lazlo,

Small update: I found the old Bolt.unitypackage in my trashcan. Restored it and I am now back working in 1.2.0.

So at least I am not stuck anymore. I just can't update.

Not a Bug

Hi Mountblanc,

I understand, and I'm glad you had an older version around. Unfortunately, there is nothing I can do to force a user to backup before importing a new version of Bolt from the asset store. This is why it is written in bold and in red in the manual's Introduction that you should always backup before downloading a new version: https://support.ludiq.io/forums/4-bolt-manual/topics/130-update-backups/

In the future, I'll create a better distribution system that allows me to include old versions, beta versions, versions awaiting reviews and source code. It should fix this kind of problem!