0
Answered

can't find the setup menu to initialize bolt

Joshua 3 years ago updated 3 years ago 8

When you first import the bolt asset into your project, you should get a menu to setup/initialize bolt. I can't bring it up and there isn't any tools menu. Maybe i'm blind but I need help!

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
+1

1st try to delete Bollt, close unity and reopen and import again from asset store. Make sure you are using Unity 2017.1 or above.

i am using a mac too. i cannot even click the download button when accessing bolt page within unity.

Peng, are you using Unity 2017.1 or above? If not the asset store should not let you download as Bolt requires  2017.1 or higher. If you are and it still will not download it may not be Bolt related. Try from the asset store webpage outside Unity.

Thanks william. I am using 5.5.4p4. Is this the latest version?

Just realised that unity has another version called 2017XXX, which is totally different from the version i am using now. Let me install the new version and try again.

It works! i think many people are not aware of the new version. What i did was only check for updates within unity and assume its the latest version. I think you should mention this to all the new users.

Peng, FYI, in the asset description it does say requires 2017.1 or above.

Answered

Hi Joshua,

Please make sure that:

  • You are using Unity 2017.1+
  • Your project has no compilation errors before importing Bolt

If both of these are good, re-download Bolt from the store; the Unity package might have gotten corrupted somehow.

yeah, you just need to have the most recent version of unity installed.