0
Fixed

In ubuntu Bolt, can not use the fuzzy finder function to enter characters.

Hyunchul Lim 5 months ago • updated by Lazlo Bonin (Lead Developer) 2 weeks ago 11

In ubuntu, an error occurs. I can not use the fuzzy finder function because I can not type anything by pressing the keyboard. It is very inconvenient to use only the mouse.

Under Review

Hi!

Could you paste the error log you get in the console when the error happens?

Something does not indicate an error message.

The error is that I can not enter any letters, when I try to use the fuzzy finder.

No warning nor error in the console?

Does the search field get "focused" (i.e. a little cursor bar on the left?)

I don't have Ubuntu installed on one of my machines at the moment, it could be hard to debug unless I know where it comes from.

Of course, The search field got 'foucused'. And I can see little cursor but it did not blink.

One more thing: I can not use the shift key in the Flow Graph, so I need to press Caps Lock to type in capital letters. This inconvenience can withstand, but the fuzzy finder is very serious problem.

This is a separate issue, but it's already fixed in v.1.2.1 (waiting for asset store approval).

I think I found something now. When I press the keyboard while holding down the left mouse button on the search area, the characters are entered. I can use a fuzzy finder like this for a while!

Ok, I'm glad you found a workaround. I'll keep this open and look into it as soon as possible.

Thank you for your prompt reply. I will be happy to wait until the problem is fixed. Bolt is the most favorite tool I've ever bought.

Fixed in Alpha

Hi Hyunchul,

In v.1.2.4, I implemented the fix suggested by the Unity Technologies developer "Tak" on this forum thread:

https://forum.unity.com/threads/editor-ui-exception.490467/#post-3199331

Hopefully, along with various input code refactor, this should help fixing your issue. Unfortunately I don't have Ubuntu installed at the moment to easily test, but please let me know if the issue persists after the next version!