0
Answered

Bolt won't open

Gu1zzin 3 years ago updated by William ianneci 3 years ago 37

Hi. I've just bought Bolt, but when I import it, it doesn't open the Setup Wizard, and I can't find any other way to install it.

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

If you have not yet, close unity and reopen then you should find Ludiq and Bolt under tools. There you will find setup and other options. 

I can't locate Tools. Where I can find it?

On the tool bar at the top of Unity, depending on the asset, you will find several under tools. If you are not seeing a tools option then you may have an issue with your download. If you have not, close Unity and reopen, if tools does do not show then  delete Bolt, close unity and reopen and download again from assett  store.

Do I need the Unity Pro to make this Asset to work?

No.  But what version of Unity are you using.

I'm using the Personal Unity, 2017.2 5.5.4

If you sent an image, it didn't came.

Sorry, for some reason all my images will not upload direct, check the link. Shows what you should see.

It showed me that error:

Unable to open Assets/Plugins/Assemblies/Ludiq.Core.Editor.dll: Check external application preferences.

Did you get tools to run setup?

No, it didn't even show the Tools menu.

Sorry. If you cannot get to setup and you tried the steps I gave you, not sure. Have to wait for Lazlo to chime in.

Pending Review

Hi Guizzin,

If the tools menu doesn't even show up, it means that:

1. Bolt hasn't imported properly from the asset store. Redownload and reimport.

OR

2. Your project doesn't compile, so Bolt cannot load. Fix any compile error in your scripts.

Let me know if you still have issues after these fixes.

Hi!
I've tried to redownload and reimport, had the same problem. About the project, I've created two new ones to try, and still had errors. What I'll do now, is reinstall Unity, and pick up an older version, to see if it works.

It worked!! Thanks for the help Lazlo and William, now I can enjoy this asset!!

Can I ask you how did you make it work? I´m still having the same original problem you had... :-(

So, you took my suggestion from discord regarding unity?

Yes I did! And it worked! At that time I couldn't do it because of the time, was 1am here in Brazil.

That  could mean there is a  comparability issue with Bolt and unitys latest build.

Hello,

I´m having the same issue. I did everything mentioned in this subject but Bolt did not worked on my unity instalation. I don´t know what to do anymore. I´ve already downgraded my unity instalation to 5.5.0f3, but bolt still doesn´t work.

Do you have any updates on why some people are having this kind of problems?

Best regards.

Bolt requires 2017.1 as a minimum requirement.  I'm not sure what caused the original problem in 2017.2, but 5.5.0f3 will not work and isn't supported.

Thaks for the answer. So I must downgrade it a little bit more.

Is there a forecast when Bolt will work on newer versions of Unity? 

Thanks in advance.

Once Lazlo the Dev sees your post he will update you on that, like all assets, when Unity updates itself it can break some things with may be the case with you latest version but he is quick to address those issues. It does work fine in 2017.2, but maybe not on the latest branches yet.

2017.1 is above 5.5. You should be able to use 2017.1, 2017.2 or even 2017.3 beta with Bolt.

Hello, I was traveling so had to leave this issue in standby for a while. Now I´m back at work again, and need some help. I´m still having the same problem.

Even if I create a new project and install Bolt in it, the setup wizard never opens and neither the tools menu is shown.

My user have full system access and still using 5.5.0f3 version.
Before importing bolt I build the project to make sure it´s working without bugs.

What can I do?

5.5.0f3 isn't new enough, Bolt's minimum version is 2017.1.

They say it is, and I believe it is. But for some reason, it doesn't work on my laptop.

It doesn't work in 2017.1 for you?  Did you get any errors on import?

No, it doesn't. Bolt is imported normally, all the instalation status bars completes well, but when looks like wizard should start, it stops and unity stays as it is.

What version of Bolt is this happening with

1.2.2, I think that it´s the most updated one.

Are you able to see the Tools menu after import? If not, close unity and re open and look again.

If the tools menu doesn't even show up, it means that:

1. Bolt hasn't imported properly from the asset store. Redownload and reimport.

OR

2. Your project doesn't compile, so Bolt cannot load. Fix any compile error in your scripts.


Thanks William, but I already did it several times, even with new projects, without any scripts. Doesn´t work. The tools menu doesn´t appear.

I will try something a little bit more "hardcore" now and will let you know the results. ;-)

+1

It worked now. :-)

It seems tha Bolt are not working with versions 5.5.4p4 or 5.5.0f3, must be a 2017 version .
I think Lazlo mentioned it somewhere here. Sorry for that.

What I did was completely remove unity from my laptop and install the most recent version of unity 2017 (2017.3.0f3).

Bolt wizard screen showed and now I can play around with it.

Thanks a lot everyone and sorry for the inconvenience. :-S

Happy new year.

+1

We all mentioned that several times, ha. All good. Yes, Min Unity ver must be 2017.1. You should join the Discord server as well if you have not, very useful.