0
Answered

How can I use leantouch?

Wagner Simões Ghidini 3 years ago updated by Lazlo Bonin (Lead Developer) 3 years ago 8

When I import the Leantouch plugin, it generates the following error in the "update unit options".

Could someone help me solve this? Because I have no idea. Thanks in advance.

Failed to provide option for 'Bolt.InvokeMember'.
System.InvalidCastException: Cannot cast from source type to destination type.
  at System.Attribute.GetCustomAttributes (System.Reflection.ParameterInfo element, Boolean inherit) [0x00010] in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Attribute.cs:273 
  at Ludiq.AttributeUtility+AttributeCache..ctor (System.Reflection.ParameterInfo element) [0x0003f] in C:\Users\Lazlo\Projects\Ludiq\Ludiq.Core\Runtime\Reflection\AttributeUtility.cs:37 
  at Ludiq.AttributeUtility.GetAttributeCache (System.Reflection.ParameterInfo element) [0x00021] in C:\Users\Lazlo\Projects\Ludiq\Ludiq.Core\Runtime\Reflection\AttributeUtility.cs:186 
  at Ludiq.AttributeUtility.HasAttribute[AllowsNullAttribute] (System.Reflection.ParameterInfo element, Boolean inherit) [0x00000] in C:\Users\Lazlo\Projects\Ludiq\Ludiq.Core\Runtime\Reflection\AttributeUtility.cs:277 
  at Ludiq.MemberUtility.AllowsNull (System.Reflection.ParameterInfo parameterInfo) [0x00000] in C:\Users\Lazlo\Projects\Ludiq\Ludiq.Core\Runtime\Reflection\MemberUtility.cs:273 
  at Bolt.InvokeMember.Definition () [0x00150] in C:\Users\Lazlo\Projects\Ludiq\Bolt.Flow\Runtime\Flow\Framework\Codebase\InvokeMember.cs:105 
  at Bolt.Unit.Define () [0x00010] in C:\Users\Lazlo\Projects\Ludiq\Bolt.Flow\Runtime\Flow\Unit.cs:93 
UnityEngine.Debug:LogError(Object)
Bolt.UnitBase:CacheStaticUnits() (at C:/Users/Lazlo/Projects/Ludiq/Bolt.Flow/Editor/Options/UnitBase.cs:119)
Bolt.UnitOptionsWizard:UpdateUnitOptions() (at C:/Users/Lazlo/Projects/Ludiq/Bolt.Flow/Editor/Windows/UnitOptionsWizard.cs:46)

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

Even in new projects, in standard folders.

I believe this may go along with the same issue I had. If so, It's a bug with property attributes or something. Either way, the bug is fixed, and Lazlo submitted already. Should be here Monday or Tuesday. 2 other fixes included as well.

You must be right. This is not a problem to compile or anything. It's just annoying. I'm sure Lazlo will fix it, the last update was great! Thank you, Jason!

Yeah no problem! It's already fixed though, so all you have to do is wait about 48 hours.

No problem if it takes longer. I asked because I thought I was doing something wrong or forgetting something. But if it's not the case, it's okay =)

Answered

The fix for this has been sent to the asset store already, just waiting for the review approval!

+1

The fix just got approved! But you won't get a notification because the version number didn't change.