+2
Escalated

Editor Crash during Aot Pre-build

Pradeep Kumar 1 month ago updated 5 days ago 5

Hi,

We are facing an editor crash when running AOT Pre-Build. It crashes immediatly after
"Finding AOT stubs in assets..." message. We are trying to make an IL2CPP Android Armv7 build.
But because of this issue we are not able to proceed. Can you please help us with this issue?

Bolt Version:
1.4.9
Unity Version:
2018.2.20f1 (64bit)
Platform(s):
Mac Editor
Scripting Backend:
IL2CPP
.NET Version (API Compatibility Level):
.NET 3.5
Need More Information

Hi Pradeep,

Sorry you're experiencing this issue and thank you for submitting a report.

Can you provide some additional information so that we may help you:

  • The error.log / Editor.log files generated after the crash (the path for them can be seen in the Unity crash reporter)
  • If this crash started happening recently, was there any third-party asset recently added to the project?

Hi Lazlo,

We recently made the decision to switch to IL2CPP. We used to use mono before, we did not face any issue with any of the assets.

I have attached the log files.

Editor.log

crash_report.log

Hey Lazlo,

I have figured out the issue. One of our custom units was in Bolt namespace. I think this must have caused some kind of recursion while generating the aot stubs leading to a crash. Changing the namespace solved it. 

Thanks

Escalated

Hi Pradeep,

Sorry for the late reply and thanks for the follow-up.

I'll still escalate this to remember to have a look in the future.

If I understand correctly, the reproduction steps are to:

  1. Create any custom unit
  2. Put it in the Bolt namespace
  3. Use it in a graph
  4. Run AOT Pre-Build

Please confirm if you have a moment!