Not exactly sure what UX I want for this, but ports should be "promotable" (in Blueprints terms) to variables, meaning a variable with a matching name would get created and automatically connected.
Promoting a value input port would create a connected get variable unit.
Promoting a value output port would create a connected set variable unit.
The naming scheme for promotion should be customizable to fit the user's taste (for example, camelCase, snake_case, PascalCase, etc.). If a variable with the same name already exists, a number should be appended (e.g. health_1).
Customer support service by UserEcho