0
Need More Information

Failed to fetch unit options for fuzzy finder

TowerCrow 1 month ago updated by Lazlo Bonin (Lead Developer) 1 week ago 2

Not sure where this is coming from, didn't appear before I added scriptable objects. Scriptable objects define a bunch of enums, and have the regular public strings, sprites, ints, etc. Some scriptable objects inherit from the base type scriptable object. The base type scriptable object has enums in it. Nothing too out of the ordinary.



Failed to fetch unit options for fuzzy finder (error log below).
Try rebuilding the unit options from 'Tools > Bolt > Build Unit Options'.
System.TimeoutException: Time-out exceeded on Unity API thread function delegate. Potential deadlock.
at Ludiq.UnityAPI.Await[T] (System.Func`1[TResult] func, System.Nullable`1[T] timeout) [0x0007a] in C:\Users\lazlo\Projects\Bolt1\Package\Ludiq.Core\Editor\Utilities\UnityAPI.cs:149
at Ludiq.UnityAPI.Await[T] (System.Func`1[TResult] func) [0x00000] in C:\Users\lazlo\Projects\Bolt1\Package\Ludiq.Core\Editor\Utilities\UnityAPI.cs:108
at Bolt.UnitBase.Subset (Bolt.UnitOptionFilter filter, Ludiq.GraphReference reference) [0x00029] in C:\Users\lazlo\Projects\Bolt1\Package\Bolt.Flow\Editor\Options\UnitBase.cs:377
at Bolt.UnitOptionTree.Prewarm () [0x00015] in C:\Users\lazlo\Projects\Bolt1\Package\Bolt.Flow\Editor\Options\UnitOptionTree.cs:44
Bolt Version:
1.4.9
Unity Version:
2019.2.14f1
Platform(s):
webGL
Scripting Backend:
IL2CPP
.NET Version (API Compatibility Level):
.NET 4.x
Need More Information

Hi TowerCrow,

Thanks for the report.

Can you send the ScritableObject script that causes the issue to start happening?

Hi TowerCrow,

Any update on this?