0
Cannot Reproduce

NotSupportedException: Specified method is not supported. Ludiq.ComponentHolderProtocol.GetComponent[T]

TowerCrow 2 weeks ago updated by Lazlo Bonin (Lead Developer) 1 hour ago 3

Shows up when opening the main project scene, no idea from where it's originating.

NotSupportedException: Specified method is not supported.
Ludiq.ComponentHolderProtocol.GetComponent[T] (UnityEngine.Object uo) (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Runtime/Utilities/ComponentHolderProtocol.cs:70)
Bolt.VariablesPanel.Object (UnityEngine.GameObject object) (at C:/Users/lazlo/Projects/Bolt1/Package/Bolt.Core/Editor/Variables/VariablesPanel.cs:196)
Bolt.VariablesPanel..ctor (Ludiq.IGraphContext context) (at C:/Users/lazlo/Projects/Bolt1/Package/Bolt.Core/Editor/Variables/VariablesPanel.cs:39)
Bolt.VariablesWindow.CreatePanel (Ludiq.IGraphContext context, Bolt.VariablesPanel oldPanel) (at C:/Users/lazlo/Projects/Bolt1/Package/Bolt.Core/Editor/Variables/VariablesWindow.cs:13)
Ludiq.GraphSidebarPanelWindow`1[TPanelContent].UpdatePanel () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Graphs/Editor/Windows/GraphSidebarPanelWindow.cs:34)
Bolt.VariablesWindow._OnSelectionChange () (at C:/Users/lazlo/Projects/Bolt1/Package/Bolt.Core/Editor/Variables/VariablesWindow.cs:20)
Ludiq.EditorApplicationUtility.OnSelectionChange () (at C:/Users/lazlo/Projects/Bolt1/Package/Ludiq.Core/Editor/Utilities/EditorApplicationUtility.cs:135)
UnityEditor.Selection.Internal_CallSelectionChanged () (at C:/buildslave/unity/build/Editor/Mono/Selection.cs:22)
Bolt Version:
1.4.9
Unity Version:
2019.2.13
Platform(s):
WebGL
Scripting Backend:
IL2CPP
.NET Version (API Compatibility Level):
.NET 4.x

I ain't 100% sure but this was likely related to our mishap with source control and missing .meta files. 

Cannot Reproduce

Hi TowerCrow,

Looking at the log and the source, this does indeed seem very weird. It looks like Bolt is trying to fetch a variables component on something that is neither a game object nor a component, but that is also a prefab definition, which is theoretically impossible. If your meta files had been scrambled, the Unity asset database might have been confused. Unless you get this error recurringly or have reproduction steps, I'll have to mark it as cannot reproduce for now. Feel free to comment again if ever you have more details.