0
Need More Information

When I build scripts with bolt they don’t work.

Doge Gamer 12 months ago updated by Lazlo Bonin (Lead Developer) 6 months ago 6

When I make a bolt script in unity, it works fine. But when I build the game, the script won’t work. I’m building for Windows and running on the same OS. Please help.

Bolt Version:
2.0.0a5
Unity Version:
2019.1.0f2
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
Need More Information

Hi Doge Gamer,

Thanks for helping us test Bolt 2. Can you provide more information about what happens? Are there logs (warnings, errors, etc.?). You can enable "Development Build" in the build settings to see if there is any log.

There are a few errors in the console saying that the Graph script on ‘(Insert graph name here)’ is out of date and will not be run on the current runtime.

Those are the scripts which aren’t working.

Hi Doge Gamer,

Make sure you run the Generator (under Tools > Bolt) to generate all scripts for your projects before building the game.

Note that this is all still in Alpha, so there might be errors or edge cases in which it doesn't work. If that happens, please paste the full stack trace on the forum to help me debug it!

how do I find the full stack trace?

Hi Doge Gamer,

You can enable "Development Build" when building, and then the console should appear within the built player whenever there is an error, along with a button to open the log file in a text editor. Please upload or paste the contents of that log file!

I will at my next opportunity!