0
Not a Bug

Bolt will not open

joshua.v.dickie 1 year ago updated by Lazlo Bonin (Lead Developer) 1 year ago 8

I purchased/downloaded/installed BOLT today (7.19.2019) and it will not import to Unity. Please let me know how to fix this issue or provide me with a full refund. I was hoping to switch to bolt after not being happy with PlayMaker but at least I could/can use their program after purchase....

If I do not hear back within 48 hours I will contact my bank and dispute the transaction and submit a review through the BBB. 

Thank you for your timely response.

Bolt Version:
I am not sure. I purchased on 7.19.2019
Unity Version:
2019.3.0a6
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

First off your using an alpha of Unity. There is never any guarantee from any publisher, that it will work, and all the kinks are worked out.

Second, not entirely sure if the store has been updated yet. If you attach your invoice through a new account on this website, you can gain access to new versions immediately, including alphas for 2.0. Also  1.4.5 was just released in the past 2 days. This one updates to allow it to work with 2019.2 and 2019.3.

If you need access to that just do the sign up.

Beware, Ludiq doesn't work on weekends, just like any other business. Chances of hearing back are very slim before Monday. But they are always great and good people. If the problem can't be resolved, they have always been happy to offer a refund themselves. No need to go through your bank. 

If you need any further help before hand, just reply or go on their Discord server, where I and many others would be glad to help.

I have downloaded and set up the older version of unity and re imported Bolt. Still, nothing happens and I am not able to utilize the program. I would just like a refund as your program is not working. I am pretty disappointed at this point but oh well.

After some extensive searching on google I was able to figure out how to get things working. Although your program is not at all intuitive, multiple youtube videos later, I will give this a try.

Glad you got it working. Was it the dot.net versioning that was the issue?

For the benefit of others who may have found this post in a search and are troubleshooting, make sure your Unity editor's scripting runtime version matches the version of Bolt you're installing. This tripped me up initially.

The recommended build of Bolt 1.4.5 is for .NET 4.x. Before you install that package, verify the following:

- In the Unity editor, go to Edit>Project Settings.
- In the column on the left, select “Player”.
- In the menu on the right, expand “Other Settings” and look for “Configuration” about halfway down.
- Under “Configuration” set Scripting Runtime Version to “.NET 4.x Equivalent”.

I'm still using Unity 2019.1.9, and it defaults to .NET 3.5. I didn't know that I needed to change it and couldn't figure out why nothing happened when I imported the Bolt package.

Ok, now it is not working and it is becoming incredibly frustrating. I am not sure why this process is so (expletive deleted) hard. I made the changes suggested above and the wizard will not proceed beyond the naming scheme. I really do not know what to do at this point. 

Please help me figure this out because nothing is making sense. What is the newest version of Unity I can use to work with bolt. 


It would really help if you actually had all of this information on your site so people don't have to pull out their hair trying to figure things out and wait for untimely help though your site. 

I have no Idea why on earth I need to set up a new account on here to actually get the latest version of this software....please just help me get things working or I will just need to go with a refund. This is just crazy at this point.

It wont let me re register on this site as you recommended.....

Not a Bug

Hi Joshua,

Sorry you're experiencing these issues.

First, from the screenshot, it seems like all you're getting are harmless API deprecation warnings. They should not have any impact on the functionality of Bolt as they are not errors. As Jason mentioned, these issues are caused by the Alpha version of Unity you're using, which we can never guarantee to be fully supported because of their frequent deprecation/API breaking changes.

Second, all these warnings stem from the Install Bolt script folder that ships with Bolt. As indicated in the readme, once you've run Tools/Install Bolt, you can safely delete this folder and these warnings should go away.

Third, you do not need to register a Ludiq account at all to use Bolt. Jason suggested this because sometimes, the Asset Store review process takes too long, so we upload the new versions directly on the website to make it available sooner to our users. In your case, you had the most up to date version already.

Overall, it looks like you simply forgot to run Tools/Install Bolt or read the README file included that prompted you to do that. I'm sorry that there's this additional step needed after the import -- it's a quirk we have to endure because Unity doesn't let us upload multiple versions of the package on the store.

Finally, if ever you're not happy with the product or can't use it for whatever reason, feel free to email support@ludiq.io for a refund. We never keep any customer against their will. ;)

Hope that helps!