0
Answered

App working in Unity but, not correctly in XCode build - need some help figuring it out

Garnette 4 months ago updated by kinginmotion 3 months ago 11

Everything looks and functions as I am expecting it to in Unity.  I did the AOT pre-build before building in Unity.  Both said successful.  In XCode however, I am getting 26,000 issues that mostly say 'this function declaration is not a prototype'.  My knowledge of coding is zero so, I have no idea what this means.  

My app looks correct on iPhone but, it does not function correctly.  The user facing data showing is correct and is set up in a start state of a state machine using AOT list literals.  The data that is not working correctly is what the user inputs are supposed to be checked against.  I am using AOT list literals and AOT list contains units for the data it checks against on button click.  The user input field is a Text Mesh Pro Input Field.  I tried previously using switch on string units instead of the lists and I had the same exact issues.  

In either scenario there are multiple correct answers and when the user input matches one of the correct answers then the 'correct' action should execute and when no match 'the incorrect action should execute'.  If there is one item on the list, it works.  In some cases the first item on the list gets recognized when the user inputs it but, sometimes it's the second or third item and other times nothing is recognized from the list, at all.  In Unity the Bolt values being passed in the graph in play mode are all correct.  I could really use some help figuring this out.  If anyone has any ideas, they would be appreciated.  Thanks.

Bolt Version:
1.4.3f2
Unity Version:
2019.3.0a2
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
+2
2019.3.0a2

That's most likely your issue. That "a2" at the end of Unity's version means "alpha 2". It's an early preview version of Unity that is not meant for serious production. Third party assets generally don't support alpha and beta versions of Unity, including Bolt. Download the latest stable version of Unity and you'll be fine. 

Please read these resources:

FAQ: https://ludiq.io/bolt/faq
Known Issues: https://ludiq.io/bolt/known-issues

Ah, thanks Towercrow.  I had no idea that’s what I downloaded.  I’ll download 2019.1.9f1 - I think that’s the one you mean.  

+1

Yes, that's the right one. 

thanks a bunch!

+1
Pending Review

Hi Garnette,

Did using a non-alpha version of Unity fix your issue?

I'll have a look at fixing 2019.2 and 2019.3 compatibility soon, but as TowerCrow mentioned it's not a priority for us to support preview versions of Unity.

Thanks for checking in Lazlo.  I'm not sure if it fixed it yet as I am having to rebuild everything.  It's going to take some time.  I tried exporting and importing my project from the alpha version to the full release version and that did not work.  I'll definitely get back in touch if it doesn't work after rebuild.

Hi Lazlo,

Rebuilding everything on the 2019.1.9f1 version of Unity did fix the functioning of my app after building to XCode, however I still get 24,520 semantic issues that all say 'this function is not a prototype'.  Hoping this does not prevent my app from getting accepted by the app store.  Please let me know if there are risks to proceeding with all these issues and if there is something I should do to fix?  Thanks a bunch!

+1
Answered

Hi Garnette,

Glad it got resolved for now.

The semantic issue seems to be a new warning on Unity's end introduced by XCode 9:

https://stackoverflow.com/questions/44473146/this-function-declaration-is-not-a-prototype-warning-in-xcode-9

https://forum.unity.com/threads/this-function-declaration-is-not-a-prototype.681799/

https://answers.unity.com/questions/1635943/build-errors-this-function-declaration-is-not-a-pr.html

I would recommend submitting a bug report to Unity about it, as there doesn't seem to be one open in their issue tracker.

Thank you Lazlo.  I appreciate the links and next steps to follow.  

Hi, I'm having a similar problem,

I was working in...

Bolt Core v1.4.5
Bolt State v1.4.2
Bolt Float v1.4.5
Unity version 2019 1.8f1
Xcode v10.2
iOS 12.3

All the macros work in Unity, but not on my iPhone after building through Xcode. I can see the scene fine on device, and Unity's physics is working. But none of the bolt macros seems to be running. Not even On Button Click.I tried upgrading all software and then building a test project, but the problem persist.

Bolt Core v1.4.5
Bolt State v1.4.2
Bolt Float v1.4.5
Ludiq Framework v1.4.5
Unity version 2019 2.0f1
Xcode v10.3 (10g8)
iOS 12.3

The new project has nothing but Bolt in LWRP, yet it’s still not function properly on device. 😭

Nevermind. I just had to do AOT prebuild. I wished that this was more clearly defined as a required step...