0
Working on Fix

Bolt 2 - DoTween when timeScale = 0

Marcel711 4 months ago updated by Lazlo Bonin (Lead Developer) 3 months ago 2

I use timeScale = 0 for game pause, however I now face the problem that the Tweens I use for UI Animation won't run anymore.

I've read that DoTween offers the possibility to change the timescale settings for the Tweens so that they run independent from the Unity main TimeScale.

Did someone already successfully change DoTween Settings with Bolt2 and can point me to solution how to solve this with Bolt2 Nodes?

Bolt Version:
v.2.0.0a5
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
Pending Review

Hi Marcel!

Thanks for this question, it made me realize that we forgot to include an input port for timescale-independant tweens in the Advanced mode of the tweening units. I'll see that this is fixed in the next alpha version.

In the mean time, unfortunately, I don't believe there's a way of doing that manually. The SetUpdate method from DOTween is a generic extension method, one of the last types of members we're not able to properly reflect yet.