0
Unity Bug

Missing UnityEngine.UI reference in Unity 2019.2 Beta

Lazlo Bonin (Lead Developer) 2 months ago • updated 1 month ago 8 2 duplicates

There seems to be an issue with Unity 2019.2 where the UnityEngine.UI DLL reference cannot get resolved, causing Bolt to fail to load. We are reporting the issue to Unity QA and waiting on a reply.

Bug report: https://fogbugz.unity3d.com/default.asp?1154163_976841tv1ld21pop

Bolt Version:
Any
Unity Version:
2019.2
.NET Version:

Duplicates 2

+1

2019.3.0a3 is an alpha version of Unity (a3=alpha 3). Bolt officially supports the latest stable releases of Unity. So download either 2018.4 LTS or the latest version of Unity 2019.1 and Bolt will work.

FAQ: https://ludiq.io/bolt/faq#unity-versions
Known issues: https://ludiq.io/bolt/known-issues

Thanks so much TowerCrow,

I flowed your instructions and I am up and running.

I will pay more attention to specifications in the future.

Danny

+1

No worries, Unity should differentiate between stable and beta/alpha releases of the engine, but they decided to mash them all together for no reason. It's a common issue for newcomers who might not know what "a3" or "b5" means at the end of the engine version.

Thanks TowerCrow

I really appreciate the warm welcome here.

Unity 2019.2 is in beta phase and Unity 2019.3 is in alpha. Since these beta and alpha versions of Unity are full of bugs and often introduce compatibility breaking changes, 3rd party asset developers usually don't officially support them.

Bolt will work on 2018.4 LTS or the latest version of 2019.1 which are considered stable versions of Unity.

Please also read the following resources:

Unity Bug

Hi,

According to Unity engineers, this is an issue on their end that should be fixed in Unity 2019.2.0b6.

See this thread: https://forum.unity.com/threads/ui.673504/

I'll update the known issues in the mean time.