+2
Fixed

Bolt 2.0.0a4 - NotSupportedException: BoltUnityEvent does not support code generation.

Christian Östman 1 year ago updated by Lazlo Bonin (Lead Developer) 8 months ago 5

When generating C# scrips with graphs using UnityEvent I get this error:

NotSupportedException: BoltUnityEvent does not support code generation.

Thanks!

Bolt Version:
Bolt 2.0.0a4
Unity Version:
2018.3.9f1
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
Pending Review

Hi Christian,

I looked into this and it's not an easy fix. It's a design limitation with the new hybrid runtime. If we point to a method on the Machine, then that method gets lost as the machine gets swapped with the generated C# script at runtime. I'll have to think about how to solve this.

Working on Fix

This will be possible in the final design of A6, but it was excluded as an oversight. Working on fix.

Fixed (Unreleased)

Thanks for the report, this will be fixed in the next version.