0

Crash/Errors when trying to generate scripts

imkeepsake 2 weeks ago 0

Initially when I tried to run a new scene in generated runtime mode I got the error:

"Graph script on 'New Sprite' is out of date and will not be run on the current runtime. Generated Version: 0. Live Version: 5"

After creating two other projects to test this, I was seeing the same error, sometimes with a different "Live version:__" numbers.

I could run it in Live and Hybrid without errors in the console though, even though the Flow Machine Hybrid Mode setting says that it's out of date.

I tried to generate the scripts, and I get 2 messages. one is:

"Script generation succeeded. 1 graphs were converted to c sharp"

but then I get an error that says:

"EndLayoutGroup: BeginLayoutGroup must be called first.Unity Engine.GUIUtility:ProcessEvent(Int32, IntPtr)"

I soon realised it was possible that the error was because my API .NET version was not set to version 4. However after making another new project and trying to generate scripts in order to run in generated mode, Unity initially crashes. After relaunching the scene and trying to generate a script again, an error will read the same error again:

"EndLayoutGroup: BeginLayoutGroup must be called first.
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)"

Bolt Version:
Bolt v.2.0.0a3
Unity Version:
2018.3.7f1
.NET Version:
.NET 4x
Bolt 2