+3
Fixed

Conflict between Bolt 2.a3 and Render-Pipeline

Iskander Karim 2 years ago updated by Lazlo Bonin (Lead Developer) 1 year ago 3

I tried to install Bolt 2.a3 in a clean project. And it failed. Any interaction with bolt, including setup wizard leads to error. If I delete the render-pipeline (both core and lwrp) in the package manager or start project without it in a first place, bolt works without any problems. Restart, upgrade from 2.a2 and various versions of render-pipeline don't help.

Alpha 2 does not experience such problems.

Message from console:

KeyNotFoundException: The given key was not present in the dictionary.System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) (at :0)Ludiq.MemberUtility..cctor () (at Assets/Ludiq/Ludiq.Core/Runtime/Reflection/MemberUtility.cs:68)Rethrow as TypeInitializationException: The type initializer for 'Ludiq.MemberUtility' threw an exception.Ludiq.TypeUtility.Instantiator (System.Type type, System.Boolean nonPublic, System.Type[] parameterTypes) (at Assets/Ludiq/Ludiq.Core/Runtime/Reflection/TypeUtility.cs:130)Ludiq.TypeUtility.Instantiate (System.Type type, System.Boolean nonPublic, System.Object[] args) (at Assets/Ludiq/Ludiq.Core/Runtime/Reflection/TypeUtility.cs:156)Ludiq.PluginContainer.Initialize () (at Assets/Ludiq/Ludiq.Core/Editor/Plugins/PluginContainer.cs:104)Rethrow as TargetInvocationException: Could not instantiate plugin 'Ludiq.Core' ('LudiqCore').Ludiq.PluginContainer.Initialize () (at Assets/Ludiq/Ludiq.Core/Editor/Plugins/PluginContainer.cs:109)Ludiq.PluginContainer..cctor () (at Assets/Ludiq/Ludiq.Core/Editor/Plugins/PluginContainer.cs:17)Rethrow as TypeInitializationException: The type initializer for 'Ludiq.PluginContainer' threw an exception.Ludiq.EditorApplicationUtility.OnProjectChange () (at Assets/Ludiq/Ludiq.Core/Editor/Utilities/EditorApplicationUtility.cs:116)UnityEditor.EditorApplication.Internal_CallProjectHasChanged () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:242)

Bolt Version:
2.a3
Unity Version:
2018.3.0f2 and 2018.3.0b12
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
+1
Working on Fix

Thanks for the report, I can see why the issue is happening from the stack trace and the codebase. Will fix for the next alpha.

Fixed in Alpha

Fixed for Alpha 4, sorry for the very late turnaround on this.